Midi Keyboard Issues

Discussion in 'Digital Audio' started by richardson.hila, May 12, 2008.

  1. macrumors member

    Aug 31, 2007

    I recently purchased an M-Audio Axiom 25 midi keyboard for my friend and there appears to be some kind of latency on their PC compared to my mac. I'm running it on a MacBook Pro via USB (2.16 ghz, 3GB ram, C2D model) with Logic Express - no lag. It runs on her PC desktop via USB also, 2.8GHZ Core Duo, 2GB RAM, Windows XP, using Ableton Live - it lags some times and not other times which is a little frustrating. Just wondering if this would perhaps be due to her sound card? Or use of usb as opposed to midi? Or is it the program itself and a lack of ram or something? I'll get more details off her tonight about her desktop config to help out. :confused:
  2. thread starter macrumors member

    Aug 31, 2007
    The PC specs are:

    Pentium Core Duo 2.8GHz
    2GB Ram
    Samsung 80GB SATA HD (windows installation)
    Samsung 400GB SATA HD (programs files, documents)
    nVidia Geforce Galaxy 8600GT 256MB graphics card

    Midi keyboard connecting through USB 2.

    Any help?
  3. macrumors 68000


    Oct 30, 2006
    Up, up in my studio, studio
    Have you checked Ableton Live's audio/MIDI settings? Sometimes you may have to add a few milliseconds of latency in order to get stable live MIDI control of virtual instruments in Windows. My M-Audio O2 hooks up to Cakewalk SONAR, and I had to set my latency to 20 milliseconds to get solid live softsynth control. Setting it to 10 or faster resulted in lag and "clipping".

    I wouldn't set it more than 25 or 30 milliseconds, though. Any longer delay would be noticeable by a keyboard player.
  4. bov
    macrumors 6502

    Aug 21, 2007
    San Francisco
    a bit off topic but didnt want to make a whole new thread.

    how are u liking the Axiom 25? im thinking about getting the 49.

    any issues/problems? ;)

Share This Page