Missing .CSS causes Safari to always display error

Discussion in 'Mac Apps and Mac App Store' started by cleanup, Feb 7, 2006.

  1. cleanup macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #1
    I used to use a style sheet to fix a visual problem on deviantART. But I decided I didn't need it so I deleted it and emptied the trash. Now, Safari constantly searches for it every time i load a new page and so it always displays "There was one error opening the page. For more information, choose Activity from the Window menu." and sure enough, the error is that it can't find the .css file that has now been deleted.

    When I go into Advanced in Preferences, under Style Sheet it says "None Selected", so shouldn't it not be searching for the bloody thing?

    It's purely a cosmetic problem, but it's really annoying having the status bar full of text all the time.

    Any ideas how I can get rid of the error?
     
  2. iEdd macrumors 68000

    iEdd

    Joined:
    Aug 8, 2005
    Location:
    Australia
    #2
    Try going to Safari/Reset Safari... It should fix the problem and will delete the history and saved form information, but leave the bookmarks.
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    Make sure you don't have <link rel="stylesheet" href="styles.css"> or similar in the head tag.
     
  4. cleanup thread starter macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #4
    That didn't work. Thanks anyways.

    Make sure I don't have it where? Where would I find this code?
     
  5. cleanup thread starter macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
  6. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #6
    Try this: Make another css file (just a dummy text file named something.css). In Safari preferenced -> Advanced choose that style sheet. Restart Safari or whatever, then go back and choose none selected before you delete the style sheet.

    Edit: Alternatively you can trash ~/Library/Preferences/com.apple.safari.plist or at least edit it to remove these two properties:
     

    Attached Files:

  7. Benjamin macrumors 6502a

    Benjamin

    Joined:
    Oct 27, 2003
    Location:
    Portland, OR
    #7
    actually it is still selected as your user defined style sheet, but when it errors it produces the None Select because safari can't find your sheet. I would suggest you select something else, then select None Selected.

    *oh Mitthrawnuruodo beat me. :)
     
  8. cleanup thread starter macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #8
    It worked! Thanks. :)
     

Share This Page