Missing Mail in Lion?

Discussion in 'Mac OS X Lion (10.7)' started by powerbook911, Jul 21, 2011.

  1. macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #1
    I am missing a lot of mail after upgrading to Lion. Things I have filed away in folders like receipts from shopping and categories like "work."

    They are still there at ME.com, but they're missing in Mail App, but not everything, just some.

    Any ideas? I wonder how I'd ever get them back? Items miss here and there from over 7 years.
     
  2. macrumors newbie

    madrussian

    Joined:
    Jul 21, 2011
    Location:
    Dallas, TX
    #2
    I have the same problem with Mail as well using Google Apps account. I have many folders missing and lots of mail missing. Perhaps Apple will address this bug in an update. Is there anything we are missing here? A certain setting or something we overlooked? Thanks everyone.
     
  3. thread starter macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #3
    madrussian

    I think I might have found most of my mail. However, Lion won't *SEARCH* for the mail.

    Odd huh?

    I wonder why Lion isn't able to find some of the mail even if I can dig through and find it myself?

    Good luck!
     
  4. macrumors regular

    Joined:
    Jan 14, 2008
    Location:
    Renton, WA
    #4
    search this forum for "mail search" and you'll find plenty of messages with people complaining about broken search in the Lion Mail app.

    I too could not search for messages that I *knew* were on my system. It was really frustrating. Search was completely useless. I had upgraded on day 1, but just last night, Mail search seemed to be working properly now. It's as if it took a while to index all my old emails, or something.

    Perhaps just give it time....if your mailboxes are large, and it sounds like they are, it might take a while.

    Another post in another thread said to perhaps right click your mailbox and choose rebuild......
     
  5. macrumors newbie

    Joined:
    Jun 20, 2003
    Location:
    Northern California
    #5
    I looked up an old thread in the Apple Discussion Forums to find out how to rebuild my Apple Mail database and it appears to have solved numerous problems I encountered, including the situation you mentioned where Lion Mail is not searching all mail or simply fails to find mail that you know for sure is there.

    To force the mail database rebuild, you will first need to navigate to ~/Library/Mail, which is currently hidden in OS X Lion. To reveal it:

    1) Open the TERMINAL application in /Applications/Utilities

    2) Type "chflags nohidden ~/Library" and hit Enter

    3) The ~/Library folder should now be visible

    Now onto rebuilding your database:

    4) First, I recommend you create a duplicate copy of your entire Mail folder (hold alt/option key while dragging it to your intended copy-to destination) just in case something goes wrong.

    5) Hopefully, your ~/Library/Mail folder contains only a single subfolder labeled "V2", click on "V2" then navigate to the subfolder "MailData" (you should now be at ~/Library/Mail/V2/MailData/)

    6) Delete all instances of files labeled "Envelope Index" or "Envelope Index-xxx"

    7) Launch your Mail application and click "Continue" at the first prompt, after which Mail should automatically begin "importing" your mailboxes.

    8) After completing this process, I found that my initial search resulted in zero results. However, after about 30 seconds or so, my search results became populated and lost/missing mail now shows up.

    Now that you completed this process, you may want to re-hide your User Library folder.

    9) Return to Terminal and type "chflags hidden ~/Library" and hit Enter
     
  6. macrumors newbie

    Joined:
    Aug 21, 2011
    #6
    I found the Terminal command suggested by KingKuel worked with as follows

    "chflags nohidden ~/Library/"

    I then followed the instructions given and re-imported my mailboxes. As with the original upgrade to Lion most of my mailboxes (42,000+ messages) were in good state but I had lost one of my Inboxes and the Sent mailbox.

    Didn't back up before the upgrade so I am guessing they are lost? There is nothing in the sent .mbox, it was DOA.

    I have two Inboxes from two different POP servers, one has bought my messages through fine, one has not (all the message headers were available after the upgrade but no content. I attempted to "Rebuild" this Inbox and lost all the header information also). Both Inboxes have exactly the same configuration - and both continue to work fine with new mail

    What the hell is going on here?
     
  7. macrumors newbie

    Altaira

    Joined:
    Dec 1, 2010
    #7
    To see the hidden Library, click Option-Go. Library will appear as an option.
     

Share This Page