Missing text when quoting.

Discussion in 'Site and Forum Feedback' started by Finiksa, Jul 9, 2004.

  1. macrumors 6502a

    Finiksa

    Joined:
    Feb 23, 2003
    Location:
    Australia
    #1
    Over the past week or so several times when I've quoted someone in a post my text hasn't appeared in the post following it. If I reload the page the text may appear or sometimes only one or two lines of what I've written. If I hit "edit" what I've written is still there but may or may not appear in the post when hit "save".

    I've also noticed post by other people that contain quotes but not response to them, so I assume it's not only happening to me.

    Any idea what's going on?
     
  2. macrumors 603

    Joined:
    Mar 2, 2002
    #2
    Well, like most software professionals do, I'm going to start off with a story to show you why that happens. Let's say someone named Jimmy X has a post like this:

    Blah 1
    Blah 2
    Blah 3

    Then his half-brother Danny Y quote all three blahs of text and responds to each one like this:

    I thought the same thing, but it would make more sense to invest if the rates came down another 1%.

    Solid point. That trend has occurred in the past twice already, so if we wait, then the rate will probably go down further.

    Right, except if you go back to your statistics from 1978 and compare the peak rate to that of 1989, you can tell that people have not invested as much as we thought they would around the end of the 1980s.


    Then Danny Y's long-lost cousin, Shara Z, quotes all of Danny Y's post. The quoted post will look like this:


    ...which excludes Jimmy X's "Blah" content. In order to include that in a post, you have to add it in manually by control-clicking (or right-clicking) Jimmy X's "Quote" button, then copying and pasting his quote tags to the correct places in the above Danny Y quote.
     
  3. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #3
    He wants to do this...

    Those really nasty embedded quotes when 5 people nest huge long quotes to each other.

    ie...

    Getting bad yet?
     
  4. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #4
    Instead of this...

    He's saying the quotes don't carry.
     
  5. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
    He wants to see this...

    I think this is what he wants, to see his post live on in others quotes. :eek:
     
  6. macrumors 603

    Joined:
    Mar 2, 2002
    #6

    I still think my original story is easier to follow.
     
  7. thread starter macrumors 6502a

    Finiksa

    Joined:
    Feb 23, 2003
    Location:
    Australia
    #7
    Actually you've both confused the hell out of me, well it's Sunday morning and I need my coffee. I get both of your points but the problem isn't as complicated as that.

    Take this post for example I've just quoted one person and typed my single response. The problem is that some times my text won't be displayed when I hit "submit" but my response is obviously being saved in the forum database because it's still there when I hit "edit". I think it's some kind of intermittent glitch in the forum software.

    So this post would end up looking like the one I'm about to post in a second.
     
  8. thread starter macrumors 6502a

    Finiksa

    Joined:
    Feb 23, 2003
    Location:
    Australia
    #8
     
  9. macrumors 68020

    Joined:
    Aug 9, 2000
    Location:
    54140
    #9
    Is it becase people edit their quotes, that they're editing parts out of what you had previously typed? :confused: I'm trying follow along with everything, but I guess we're just not clear on what you mean exactly.
     
  10. macrumors 68020

    Joined:
    Aug 9, 2000
    Location:
    54140
    #10

    Well, you didn't quote yourself... so why would it show up? (am I making sense?)
     
  11. macrumors 603

    Joined:
    Mar 2, 2002
    #11
    I can see this going nowhere... post your question over here if vBulletin's FAQs and already submitted help topics (you'll have to search to see if somebody had the same issue) aren't of any help. Technical vBulletin issues should be addressed to vBulletin, as MacRumors doesn't have complete control over the software and can't debug/fix code-level bugs.
     
  12. Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Kepler-452b
    #12
    I have no theories about this quirk/bug. I sometimes come across posts with a quote and no comment (which I delete in my role as moderator) and I'm puzzled what the poster had in mind. Perhaps your problem explains it - the same bug happened to them.

    If you do figure out the mystery, Finiksa, please post what you learn in this thread.
     
  13. thread starter macrumors 6502a

    Finiksa

    Joined:
    Feb 23, 2003
    Location:
    Australia
    #13
    This one's still happening for me.

    I've tried searching the vBulletin troubleshooting forum a few times but haven't been able to find anything similar to this. I did notice vBulletin is up v3.0.3 and MacRumors is running v3.0.0, perhaps this problem has been addressed in a later point release. I think it's just going to remain a mystery for now, at least I know it's not just happening to me now.

    For reference here's a screen grab, before and after a page reload.
     

    Attached Files:

Share This Page