ML Desktop and Screensaver issues

Discussion in 'OS X Mountain Lion (10.8)' started by borostef, Jul 27, 2012.

  1. macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #1
    Since today I have this problem, when I try to open Desktop and screensaver options in system preferences it freezes and just stays like that. I have to force quit system preferences. All the other options in System preferences are working fine. Any ideas?
     

    Attached Files:

  2. macrumors member

    Joined:
    Apr 28, 2011
    #2
    Wow, I have the exact same thing here. I plan on calling AppleCare today. Something has gone corrupt.

    ----------

    Also, I did a re-install yesterday but that did not help. FYI
     
  3. thread starter macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #3
    Could you please post the Apple cares reply here since I don't have any :(
     
  4. thread starter macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #4
    I have tried verifying disk permissions, no joy, still the same problem :mad:
     
  5. thread starter macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #5
    I have figured out that if I change to the "Guest" user account desktop and screensaver system preferences work just fine... Why are they not working in my account?
     
  6. macrumors 603

    Michaelgtrusa

    Joined:
    Oct 13, 2008
    Location:
    Everywhere And Nowhere
    #6
    Try a clean install.
     
  7. macrumors member

    Joined:
    Apr 28, 2011
    #7
    OK, I was on the phone with Apple Care for two hours. They finally figured out that a folder in my preferences was corrupt. i can't even begin to tell you how he fixed it. But, we did not have to do a clean install and he was able to save most of my preferences. Only my basic preferences had to be redone by me going through all the settings in my system preferences. Sorry I don't have a better answer for you. No clue how this happened, other than it was caused by my upgrade to ML. You are right that if you go in and set up a new user, everything worked perfect. Luckily he was able to save all my other preferences like my Docs, Music, Pics, etc...

    Good luck and I hate to say that you should do a backup and maybe to a clean install and then copy all your files back in.

    jkk
     
  8. thread starter macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #8
    TY for your effort, I guess I will have to live without my screensaver for now :(
    Maybe it will be fixed with the next major OSX release ;)
     

Share This Page