ML Do you want the application “iTunes.app” to accept incoming network connections?

Discussion in 'OS X Mountain Lion (10.8)' started by ravinder08, Apr 24, 2013.

  1. macrumors regular

    Joined:
    Jun 11, 2010
    #1
    Keep getting Do you want the application “iTunes.app” to accept incoming network connections? when I open iTunes. I've even re-installed OSX using recovery mode. I have to type in my username and password this never happened with SL and it's getting really annoying.

    Thank you
     
  2. macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    Don't reinstall the OS because of a problem with one app. There are very few reasons why you need to reinstall the OS to fix a small problem of this sort.

    Make sure you have the latest version of iTunes. There was a bug in early versions of 11, but it's been fixed now.
     
  3. macrumors member

    Donut4000

    Joined:
    Aug 28, 2009
    #3
    I used to get that error on previous versions - and it never seemed to go away regardless of how often I ok'd it. I saw several fixes that involved quite a bit of tinkering with the guts of the actual app - I don't really remember specifics as it seemed just too much hassle at the time. What did fix it for me was to simply uninstall iTunes, then reinstall a fresh and up to date version. Much simpler that the alternative as I remember, and it worked without problem.
     
  4. thread starter macrumors regular

    Joined:
    Jun 11, 2010
    #4
    Did the OSX re-install as adviced by applecare, still didn't work! Unfortunately there's no way of uninstalling itunes on ML.
     
  5. macrumors 68020

    Joined:
    Jun 15, 2012
    #5
    Don't uninstall it, just install the latest version. It was a known bug with the code signing, so that iTunes would constantly be seen as a different version of itself every time it launched.

    Install the latest version.
     
  6. thread starter macrumors regular

    Joined:
    Jun 11, 2010
    #6
    tried that already still getting the message
     
  7. macrumors member

    Joined:
    Jul 29, 2011
    #7
    I'm having same problem with plex server. Upgrading plex didn't help either.
     
  8. thread starter macrumors regular

    Joined:
    Jun 11, 2010
    #8
    done a fresh erase and install, worked out without any problem, then I migrated from my TM backup and same problem came back! So something to do with the settings being transferred from my TM backup which was SL. How can I resolve this?
     
  9. macrumors 603

    justperry

    #9
    Just try this, make a new User Account, then login into that account and see if it is the same there, if not you know 100% sure it is data imported into your normal user account and can be resolved by moving/deleting certain files.
     
  10. thread starter macrumors regular

    Joined:
    Jun 11, 2010
    #10
    Thanx for this advice, new account worked perfectly so it's defo the data that was imported. What can I do now?
     
  11. macrumors 603

    justperry

    #11
    This means it is almost sure to be in the Users Library Folder, the first thing to think of is iTunes Preferences, it is located in:

    /Users/****/Library/Preferences

    **** is your Home Folders name

    the files you should move are:

    com.apple.iTunes.eq.plist
    com.apple.iTunes.Gracenote.plist
    com.apple.iTunes.plist
    com.apple.iTunesHelper.plist

    Actually, any file starting with com.apple.iTunes , move them to the desktop before launching iTunes, launch iTunes and see if it happens again, if it does drag the files back to the Preferences folder to get your former preferences back.

    Keep in mind that the Users Library Folder is invisible in Lion and Mountain Lion, if you need assistance to make it visible just ask, actually I will tell now.

    To make the Folder visible open terminal and type the following

    chflags nohidden /Users/****Library

    Replace **** with your Home Users name
     
  12. macrumors 601

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #12
    Follow these steps:

    1. Quit all other running applications.

    2. Hold down the 'option' key while clicking on the Finder meny item 'Go' and select 'Library'.

    3. When the 'Library opens up go to the folder 'Preferences' and sech folder th file "com.apple.iTunes.plist" and move it to you Trash can (but don't delete it just yet).

    4. Startup iTunes, set your iTunes Preferences again and see if that helps.


    If this does not help you can quit iTunes and put that file back into the Preferences folder to go back to the beginning.
     
  13. thread starter macrumors regular

    Joined:
    Jun 11, 2010
    #13
    Just tried it and still got the message appearing:mad:
     
  14. justperry, Apr 26, 2013
    Last edited: Apr 26, 2013

    macrumors 603

    justperry

    #14
    OK, next thing to try, rename the iTunes Folder to iTunes Old, then start iTunes, everything is reset, what happens now?

    You can rename the iTunes Old Folder back to iTunes after you did the test, delete the newly created folder though, be sure nothing got imported into iTunes otherwise you'll loose stuff.

    Edit: There is many more things you can do to solve this problem, one of them is to clean your Caches Folder, we should have tried this one before renaming the iTunes Folder, if the above didn't work move all files and folders inside the ?Users/****/Library/Caches to the trash and try again.
    **** is again your User Folder name.
    We will find it although it will become a bit more complicated later on, I will tell you later after you tried the above.
     

Share This Page