ML no sound for new mail

Discussion in 'OS X Mountain Lion (10.8)' started by radu.valeriu, Aug 5, 2012.

  1. macrumors newbie

    Oct 26, 2008
    Bucharest, Romania

    Just updated to ML and now when I receive a new mail there's no sound playing! I just get the badge and the banner but no sound.

    In System Settings / Notifications the settings for mail are "Badges, Sounds, Banners".

    Anybody else came across this problem? Any advice?

  2. macrumors P6


    Jan 23, 2005
    You have to pick the sound you want in the Mail app preferences, not in Notifications.
  3. macrumors 6502a


    Oct 29, 2008
    isn't the sound picked up by default? I mean I was not setting any sound after installation/upgrading to ML and there was classic "Ding" (in ML its "New Message Sound") once email arrived.:)
  4. macrumors P6


    Jan 23, 2005
    I think on a default clean install there is a sound. But I do know from tinkering with ML, the Mail sound is set in Mail app prefs.
  5. macrumors newbie

    Jul 26, 2012
    There are two solutions that work for me: Applescripts and Repair Permissions (this method need to be repeated overtime)

    I. Applescript

    The solution is to set a rule in Mail Preference to run an Applscripts if there is new email. This Applescript will play a notification sound of your choice:

    tell application "Mail" to if (count of (every message of inbox whose read status is false)) isgreater than 0 then do shell script "afplay '/Applications/ Mail.aiff'"

    You can change the path /Application/ Mail.aiff to any folder that containt an aiff file. For example: /System/Library/Sounds/Glass.aiff (in this folder you can find all the alert sounds of Mac OS)

    Applescript Editor

    1. Open Applescript Editor in Applications folder

    2. Paste the script in after choosing your notification sound path

    3. Save in ~/Library/Application Scripts/ (can name it New Mail in my example)

    4. Now you can choose the script in Mail Rules setting

    For the Mail rules setting

    Open Mail Preferences then Rules then Add Rule. The setting like photo

    It works like a charm !!!

    II. Repair Permissions

    1. Quit Mail app

    2. Go to Applications folder/Utilities/Disk Ultilities

    3. Select Macintosh HD then Repair Dish Permissions

    Wait for a couple of minutes, open Mail and try to send yourselft an email again (remember to off the rule to see effect). This method is need to be repeated overtime so I still prefer the Applescript method.

Share This Page