ML-Server and iTunes.

Discussion in 'Mac OS X Server, Xserve, and Networking' started by mwhities, Dec 2, 2012.

  1. mwhities, Dec 2, 2012
    Last edited: Dec 2, 2012

    macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #1
    I am running ML 10.8.1 right now with Server 2.1.1 and I can't update my iTunes. Is this something Apple set up or what? When I click Software Update, it states no updates available. I have iTunes 10 running.

    Anyone else experience this?

    I use this to share all of my music to all of my devices. Please post up if anyone else has had this issue. (Not that it's a big deal but, I actually like the new interface.)

    (EDIT: Added screen shot.)
     

    Attached Files:

  2. macrumors 6502a

    Joined:
    Sep 10, 2012
    #2
    Hi mwhities,

    I'm using 10.8.2 Server and was able to get iTunes 11 from Software Update. I also got iTunes 11 from Software Update on a 10.6.8 Server box.

    A workaround for you, as I'm sure you already know, it to go to Apple's iTunes web page and manually download iTunes 11 and install it.

    Regards,
    Switon
     
  3. macrumors 68040

    Joined:
    Jul 11, 2009
    #3
    Something is broken in your OS- you should be seeing the 10.8.2 updates too. Are you running the software update service on your server? You may need to enable the latest updates if you are.
     
  4. mwhities, Dec 2, 2012
    Last edited: Dec 2, 2012

    thread starter macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #4
    Thanks.. I will do that, I just gotta figure out why I'm not getting updates. I think my last update was a few weeks ago for an app.. nothing with the OS.

    ----------

    I'm trying to figure out what exactly is wrong with it. I had SU running but, I disabled it and ran "sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate CatalogURL" to default to Apple's servers. Still nothing. I may do a reinstall, I have been "learning" MLS... Changing things here and there.

    Thanks and I'll keep this posted.
     
  5. thread starter macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #5
    So if I check for updates within iTunes, it shows there is an update.

    I select download to update and the App store shows there is no updates.
     

    Attached Files:

  6. macrumors 68040

    Joined:
    Jul 11, 2009
    #6
    Again, since you were running the software update service, and aren't shown the 10.8.2 updates, something else is broken. Have you rebooted since you deleted the Software Update server URL? You can also delete the preference file manually, which might work better.
     
  7. thread starter macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #7
    Yes, I wasn't previously running (I did start it but, then stopped it a few months ago) software update and then tried before I posted this, with it running.

    I had bought the Server.app as I want to learn more about the OS and Server so I could start certing (ACSP/ACMT). I had removed, re-added, configured, and reconfigured so much on the server, I would have spent less time reinstalling/setup then to try to figure it out.

    So that's what I did, I installed ML 10.8.1 and then upgraded to 10.8.2 and iTunes11. I was able to get all of the services I wanted to use running and I organized the shares better/differently. It was easier than I imagined but, I guess it was easier as I had everything stored on the spare 750G drive (data doubler) and my 64G SSD drive only had what I downloaded, when I used it as a desktop. So a quick wipe and install. Not sure how long it took but, way faster and cleaner than what it was.
     

Share This Page