MMS & Voicemail not working on iPhone 4 (JB + Unlocked)

Discussion in 'Jailbreaks and iOS Hacks' started by HXGuy, Aug 8, 2010.

  1. macrumors 68000

    Joined:
    Mar 25, 2010
    #1
    Anyone find a fix for this yet? I can't get MMS messages to send or receive and my Voicemails aren't being pushed through to the phone either. Seems to have started since the Ultrasn0w unlock.
     
  2. macrumors regular

    Joined:
    Apr 2, 2010
    #2
    remove ultrasnow will fix this
     
  3. thread starter macrumors 68000

    Joined:
    Mar 25, 2010
    #3
  4. macrumors regular

    Joined:
    Sep 11, 2008
    Location:
    Goodyear AZ
    #4
    Yup. I lost my MMS a few days after ultrasn0w. It worked right after I unlocked it but a few days later MMS stopped working.

    SMS worked, just no MMS.


    I removed ultrasn0w and the MMS came right back.
     
  5. macrumors member

    Joined:
    Jul 13, 2010
    #5
    Does removing ultrasnow repo puts the phone back to "lock" status?
     
  6. macrumors regular

    Joined:
    May 19, 2008
    #6
    This fixes the problem completely?

    I believe that it does. Not 100% though
     
  7. macrumors regular

    Joined:
    May 19, 2008
    #7
  8. macrumors 6502

    Joined:
    Jun 23, 2010
    #8
    I have the issue and I did the iphonedelivery fix from the Redmondpie post a few days ago. It seems to kill the unlock as the carrier selector is gone from the options menu, but it does alow you to send MMS.

    Rebooting brings the unlock back, with no MMS. I am staying on ATT and only ran Ultrasn0w because I will be travelling to Mexico in a month and want to use a local SIM there. I just uninstalled the unlock and will reinstall it when I leave.
     
  9. macrumors regular

    Joined:
    May 19, 2008
    #9
    Cool. Currently in Europe and am wondering when they will patch the glitch so all the features will work
     

Share This Page