MobileMe email picks up .mac extension on replies

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by bizcoach, May 13, 2010.

  1. macrumors newbie

    Joined:
    Nov 24, 2009
    #1
    When I purchased MobileMe, I chose a mobileme email address. When I send from that address, ie: me@me.com, and recipients reply to that email, the email address that populates back is me@mac.com. I do not have a .mac address and thus the senders receive an undeliverable message. How do I get rid of the .mac extension on replies? It happens with everyone so I'm assuming there is a setting somewhere I'm missing?
     

Share This Page