MobileMe keeps crashing and "appleMobileDeviceHelper has stoped working"

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by ivenus, Jun 19, 2009.

  1. macrumors member

    Oct 21, 2007
    Hello im running a Vista Home and mobileme keeps crashing and says mobileme pref. has stoped working and when i plug in my phone i get AppleMobileDeviceHelper has stoped working and i dont know how to fix it
  2. macrumors 68020


    Jul 11, 2007
    Torrance, CA
    Do you mean MobileMe Control Panel (Preferences) keeps cancelling or the web interface to MobileMe or iTunes?

    If iTunes or Control Panel I would uninstall and re-install. Or just install latest release of iTunes 8.2 (if not already there) and it will upgrade you Control Panel as well.

    If the browser then I recommend you use Safari 4.
  3. thread starter macrumors member

    Oct 21, 2007
    When i connect my iphone into itunes i get that error. and on my computer on the bottom right i right click and pref. then it crashes.
  4. macrumors newbie

    Jun 20, 2009
    Fixed applemobiledevicehelper crach...BUT

    After way too much and unnecessary fiddling and diddling and research, I finally managed to get my Vista Ultimate version of iTunes to communicate/sync with my iPhone without crashing (usually, “AppleMobileDeviceHelper has stopped working”). To do this I had to (1) except/exempt iTunes from my antivirus software (Kaspersky); AND (2), set iTunes to always run “as administrator”.

    To accomplish the latter, I went to the iTunes.exe file location and right clicked to get to the Properties dialog. I then clicked on the Compatibility tab to get to and set the check box “Run this program as an administrator.” All well and good.

    But now, …

    Even though “run as administrator” is, by definition, a “Privilege Level” setting and NOT a compatibility option, every time I load/run iTunes, I get nagged by the following so-called “compatibility mode” error message:

    “iTunes.exe has been set to run in compatibility mode for an older version of Windows. For best results, turn off compatibility mode….”

    Well now, compatibility mode is in fact NOT checked for any earlier version of Windows!

    I reported this nag bug at the Apple website but without much hope that I would get a reply much less any action. If anyone else has a way to kill this nag, it would be greatly appreciated.

Share This Page