MobileMe Mail Beta Now Live

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by macduke, May 18, 2010.

  1. macduke
    Expand Collapse
    macrumors 603

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #1
    Go log in! I just got my confirmation via email.
     
  2. danielforman
    Expand Collapse
    macrumors regular

    Joined:
    Sep 29, 2007
    #2
    Just got my confirmation and logged in. Looks pretty good.

    I like the new drop down menus across the top, they make it feel much more like a native application rather than a webpage and I guess the design moves somewhat towards the iPad interface (From what bit I have seen of the iPad interface).

    Search results display fairly quick as well. Overall at first glance looks good. Will have a bit more of a play with it later on.
     
  3. canada eh
    Expand Collapse
    macrumors regular

    Joined:
    Dec 22, 2009
    Location:
    Barrie, Ontario
    #3
    I got the email at 10:30 friday night and I logged on, and it is a very nice UI change that will stay, I just want Apple to carry over the UI and speed improvements over to the rest of the site
     
  4. NeuralControl
    Expand Collapse
    macrumors 6502a

    Joined:
    Dec 3, 2009
    #4
    I received my confirmation email today. So far it looks pretty good. I like the UI.
     
  5. Opstech
    Expand Collapse
    macrumors 6502a

    Opstech

    Joined:
    Jan 5, 2010
    Location:
    California
    #5
    beta issues

    Is anyone having issues with the ME beta today?

    Sometimes it takes 2 min to delete an email and then It wont let me log in from other computers. It just gives me the spinning wheel
     
  6. Morod
    Expand Collapse
    macrumors 68000

    Morod

    Joined:
    Jan 1, 2008
    Location:
    On The Nickel, over there....
    #6
    Over the last two or three days, it seems it's been unavailable more than it's been available, at least for me.
     
  7. my2geldings
    Expand Collapse
    macrumors member

    Joined:
    May 31, 2010
    #7
    For me the problems started today. I'm unable to send any form of file. Arrive in the receivers inbox with a question mark. Quite annoying.
     

Share This Page