Mountain Lion Password Enter Lag

Discussion in 'MacBook Air' started by Sid-R, Aug 1, 2012.

  1. macrumors member

    Sid-R

    Joined:
    Dec 8, 2010
    #1
    Since I updated to ML.. whenever I open the lid to wake my MBA from sleep.. The screen comes up pretty quick but when I type nothing registers for quite a few seconds and then after a lag period of a few seconds I am able to type my password... This was never the case before.
    Anyone else experiencing this?
     
  2. Guest

    eric/

    Joined:
    Sep 19, 2011
    Location:
    Ohio, United States
    #2
    Yes. I think it's due to the amount of time that the MBA has been inactive. I think it takes a second to restore complete functionality from sleep. So far for me, if I close the lid and then open it within a few minutes I don't experience the lag.
     
  3. macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #3
    Yes definitely experiencing this! Thought ML was going to make my Air more "Instant On" like it was in Snow Leopard and the screen does come up fast, but the lag to put in password just ruins it.
     
  4. macrumors member

    Joined:
    Mar 9, 2012
    Location:
    Maple, Ontario, Canada
    #4
    I noticed the same lag on my MacBook Air too :-(
     
  5. macrumors newbie

    Joined:
    Dec 6, 2011
    #5
    Disk Utility Repair fixed my lag

    Installed ML on MBP, experienced significant lag as discussed... ran the repair feature in disk utility and everything is zippy again.
     
  6. macrumors newbie

    Joined:
    Jun 23, 2012
    #6
    After 4200 seconds (1 hour and 10 minutes) of sleeping, the MBA silently hibernates itself to conserve battery power. Waking up from hibernation takes a few seconds, whereas waking from sleep is almost instantaneous.

    You can change that period with a little techie know-how, but I wouldn't suggest doing so, because it's a reasonable default.

    Perhaps knowing the reason for the delay will help give you the patience to wait those few seconds. :)
     
  7. macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #7
    After you did this, how many seconds from the time your screen turns on and the time you can actually enter your password? Can you enter your password immediately?
     
  8. macrumors 6502a

    Beanoir

    Joined:
    Dec 9, 2010
    Location:
    51 degrees North
    #8
    i'm also having the same issue. It's not a big issue I admit, but would be nice if it wasn't like it!
     
  9. macrumors newbie

    Joined:
    Dec 6, 2011
    #9
    Instantly... I cannot see any lag or delay from the time I open the screen and typing has zero delay, zero delay after password is entered... after I ran the repair tool in disk utility. Try to run verify disk and then repair if needed... worked for me.

    Something in the ML installation caused problems with the disk and slowed things way down... after running repair it was much faster.
     
  10. macrumors 6502

    Joined:
    Jun 10, 2012
    #10
    I noticed this too, and just disabled Power Nap. It seems to have disappeared, but I only have one instance of starting it up to use as my benchmark (meaning I only let it sleep a few hours one time so far).
     
  11. macrumors 6502

    Joined:
    Jul 28, 2011
    #11
    I have the same problem but there's no lag if the MBA is connected to the power socket. Power Nap enabled but not on battery (if that makes a difference).

    Repairing disk permissions, hopefully that'll work. Thanks none the less :)
     
  12. macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #12
    I have repaired and still have the lag.
     
  13. macrumors 6502a

    mathcolo

    Joined:
    Sep 14, 2008
    Location:
    Massachusetts
    #13
    Did you repair disk permissions in addition to the standard "Repair Disk"?
     
  14. macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #14
    Couldn't repair disk cause after it verified "Repair Disk" was greyed out. Do I need to repair it from the recovery partition disk utility?
     
  15. macrumors newbie

    Joined:
    Jul 24, 2012
    Location:
    New Delhi, India
    #15
    Computer -> Macintosh HD -> Library -> Cache {delete all files inside cache folder}

    Then right click on trash bin and press Command, click SECURE EMPTY TRASH

    ----

    Report back if you see some improvement
     
  16. macrumors newbie

    Joined:
    Jun 23, 2012
    #16
    There's no connection with PowerNap. Even with it disabled, the default behavior is as I described above.
     
  17. macography.net, Aug 2, 2012
    Last edited: Aug 3, 2012

    macrumors newbie

    macography.net

    Joined:
    Apr 3, 2011
  18. sanityinc, Aug 2, 2012
    Last edited: Aug 2, 2012

    macrumors newbie

    Joined:
    Jun 23, 2012
    #18
    There's a lot of voodoo being invoked here. Before those affected go clearing their caches and repairing permissions - only to find that the delay persists when their computers sleep for longer periods - please take a moment to read the information I posted above.
     
  19. macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #19
    Yes after I cleaned the cache and repaired the disk from disk utility I still get the lag when it has been asleep for more than an hour. I know it's the hibernate mode that is causing this, but it didn't happen under Snow Leopard so why must it happen now and under Lion?
     
  20. macrumors newbie

    Joined:
    Jun 23, 2012
    #20
    Lion added the "Standby" feature, whereby the computer switches from sleep to hibernation after a predefined period. (I believe the feature is not supported on all hardware -- it certainly wasn't on my early unibody MBP. That machine had a user-replaceable battery, so removing the battery during standby sleep would leave the computer no chance to create a hibernation file.)

    The default behavior in Snow Leopard - or when the hardware does not support Standby - is to create the hibernation file at sleep time and then keep sleeping until the battery gets critically low.
     
  21. macrumors 6502a

    Joined:
    Oct 14, 2008
    Location:
    Brazil
    #21
    has anyone found a solution yet? I've this problem aswell.
     
  22. macrumors 68020

    Acorn

    Joined:
    Jan 2, 2009
    Location:
    macrumors
    #22
    ive noticed this as well. i open the lid then type my password and it fails because half the password wasnt typed because of the delay. its not that big a deal but annoying none the less.
     
  23. macrumors 68020

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #23
    Opposite issue here

    I was seeing this same issue on my 2011 MBA when it was running Lion. It would sometimes take a second or 2 to wake then another second or 2 before I can type.

    But since updating to ML, the problem is gone. Whether is was sleeping for 5 minutes or overnight, it boots up instantly and there is no type lag.
     
  24. macrumors 6502a

    Joined:
    Oct 14, 2008
    Location:
    Brazil
    #24
    Mine was like this in Lion. Since upgrading to ML I'm with that issue. I don't remember if it started to happen after installing the powernap firmware upgrade.
     
  25. macrumors 68020

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #25
    I have the Powernap update installed, but I'm not sure if this affected performance or not, as I installed it as soon as ML finished installing.
     

Share This Page