Mouse "lag" / jerky movement

Discussion in 'iMac' started by magyarangol, Aug 17, 2011.

  1. macrumors newbie

    Aug 16, 2011
    My apologies if this has been discussed elsewhere. I have looked but to no avail.

    Having made the switch this week and spending an absolute fortune on my new very sexy iMac, I cannot express how dissapointed I am with this mouse "lag" issue.

    Is there a solution to this problem or is it simply something I have to get used to? Not that I want to get used to it as I work heavily with Lightroom and Photoshop and trying to use the mouse/pointer is simply disastrous.

    It tracks on some parts of the screen fine, but then it sort of runs into a sticky patch for a couple of seconds, slows down and sort of jerks on. It then goes back normally and then hits another part of the screen and repeats the process.

    I am using the 2011 new iMac i5 with 12 GB of RAM and I have tried the Magic Mouse (lags) a wired Logitech Mouse (same problem but heavy lag) and even the magic track pad.

    Please help :(
  2. macrumors member

    May 13, 2011
    I'd head straight to the Genius Bar if there is an Apple Store nearby. If not, call Apple Support.

  3. macrumors member


    Jan 26, 2011
    I have a similar problem, but the problem only happens when i have my mini display port connected. if the second monitor is off, and plugged in, the mouse would lag. But if i turned on the second monitor, no mouse lag at all. very strange, can't figure it out.

    O ya, 27" i7, SL
  4. macrumors regular

    May 14, 2003
    This is not normal. I've never had mouse lag even back to a MacPlus in 1989. You have some issue, and Apple will be more than happy to help you with it.

    Everytime I've visited the store or called them they are very very gracious. They've made me feel as if I'm the only person in the world.

    BTW, I've had the impression that these guys like to be stumped. I think they have special deal with the company to have good things happen to them if they can find some problem that no one has ever heard about
  5. thread starter macrumors newbie

    Aug 16, 2011
    Thank you for the replies. I contacted Apple support last night, very helpful, and we went through many tests to resolve. The Mac is only 2 days old so quick to look through etc. They found no issues (hardware & software) and couldn't resolve my problem.
    I installed some 3rd party drivers for the mouse, namely "Steermouse". It has helped a little bit to resolve the acceleration curve but it's still not as smooth as windows :(

    I will be buying a compatible Logitech M500 today as reports from net say it's good. Will install all drivers and see if that helps. It may just be the wireless/bluetooth connection? I hope so at least.
  6. macrumors newbie

    Apr 27, 2008
    San Jose
    For what it's worth, I just installed a Logitech M500 today and it is great. You kind of have to tinker with the tracking speed on both the Mouse and the Logitech control panels, since they both interact with each other, but I did end up finding a setting that I liked.

    I did not have any mouse issues with the Apple mouse though, I just like the Logitech's shape and button layout better.
  7. thread starter macrumors newbie

    Aug 16, 2011
    Thank you for this
  8. thread starter macrumors newbie

    Aug 16, 2011
    Problem resolved.

    Removed the wireless (bluetooth) Magic Mouse installed drivers for the Logitech M500 Corded mouse ;)

    Re-booted, connected the USB to Mac = Pure and utter awesomeness :D
  9. macrumors regular

    May 14, 2003
    The blue tooth keyboard and mouse are elegant. But for a desktop machine which never goes anywhere but stays on the desk, they are not really needed. I have a gread logitech mouse which is a USB wired thing. The keyboard is the bluetooth variety and its nice to set it aside to do some work on the desk like a real desk. But the mouse simply moves to the side.

    Glad you can see what a mac is really like.

    My wife asked me yesterday as I was reveling in the integration of Aperture, iTunes, iDVD, and iMovie as I was making a slide show movie of my daughter's child hood pictures for her to have, whether there was anything in the pc(Dell etc) world that I missed. I said emphatically NO. I've always had macs, and apples since the Apple 2 in 1983. I've had to use a nice Dell and then Lenovo lap top running windows since 1995 at work before I retired. I can use them fine. But I would never ever(did I say NEVER?) choose one over a Mac.
  10. macrumors newbie

    May 11, 2011
    I was having probably the same problem few days ago with new mouse (Logitech Performance MX).After few days trying everything i can think off i found out that lag appears when second monitor is attached to thunderbolt(minidisplay)-dvi.

    Am having this problem on SL.Nothing helped except that.
    But thats not really a solution.
  11. macrumors newbie

    Sep 24, 2013
    SOLUTION now to the huge problem of Mouse lag b/n 2 screens

    I registered just to post this, because of good karma. I googled this topic, found this thread, but also found this from an engineer who finally couldn't take it, and created software to fix this: <--- it's FREE, but you should donate. Untold hours and hours of higher productivity due to this amazing fix, which installs as a new Preference Pane, and has spped controls for both mouses and trackpads.

    Here's his original blog entry upon creating this solution
  12. macrumors regular


    Oct 9, 2003
    Austin, Texas
    Just in case anyone gets to this old thread like I did, here is a solution that worked for me.

    The second reason your Magic Mouse may be skipping or hesitating is that debris, dirt, dust, and gunk have become lodged in the mouse's optical sensor. There's a simple fix for this, one that just requires giving the sensor a good cleaning. No disassembly is necessary. Simply turn the offending rodent over and use compressed air to blow out the gunk. If you don't have any compressed air on hand, just blow into the sensor opening. When you're done, take a moment to clean your mouse pad or the desktop area where you use your Magic Mouse. Even though the Magic Mouse uses optical tracking, it can still pick up debris that can prevent its tracking mechanism from working correctly.

    There is an additional tip at the link on making sure the battery has good contact.

    There can be numerous reasons for a Magic Mouse to drop the Bluetooth connection, but in my experience, the most common reason is a loose battery terminal contact in the Magic Mouse.For me, the major cause of the Magic Mouse dropping the Bluetooth connection can be traced to the Magic Mouse's battery compartment, and what appears to be a weak design for the battery contacts. Essentially, it's possible for a small jolt, such as lifting the mouse to reposition it, to momentarily cause the battery terminal in the Magic Mouse to move, thus breaking the electrical connection. No power, no Bluetooth connectivity.This may be the result of a weak spring in the contacts, as well as a poor contact design. Either way, the fix is simple.

    Remove the batteries from the Magic Mouse.
    Cut a small piece of aluminum foil about ½-inch square in size.
    Wrap the aluminum square around the negative terminal of the battery.
    Re-insert the batteries into the Magic Mouse.
    The extra thickness of the aluminum foil produces a bit of additional force wedged between the battery and the spring-loaded contact. This makes the battery less likely to be jarred away from the contact when you move the Magic Mouse around.

    This may be enough to fix most Bluetooth disconnect problems, but if your Magic Mouse still experiences an occasional disconnect, there's one more modification you can try.

    Remove the Magic Mouse battery cover.
    Cut a piece of paper into a rectangle about 1 inch by 1-½ inches.
    Place the paper on top of the batteries, roughly centered. Tuck any excess paper around the edge of the batteries.
    Re-install the Magic Mouse battery cover.
    The extra paper acts as a wedge between the batteries and the battery cover, to help hold the batteries in place.These tricks worked for me. I haven't had any Bluetooth disconnect issues since putting these fixes in place.
  13. macrumors newbie

    Apr 15, 2015

    I've had this issue and read many threads similar to this trying to solve.

    ◊ MacBook Pro (New/Purchased Jan2015 | OSX Mavericks | 2.5GHz | 15" Retina)
    ◊ Logitech M510 (New w/ K350 Keyboard)

    Problem Summary:
    My Logitech mouse lags/stutters/jumps/skips/etc sporatically when my Mac is connected via Thunderbolt to an external LCD. It tends to happen in short 'fits' or limited periods of time. It persists regardless of CPU/Memory usage (it happens even when no applications are running). Sometimes it works fine for hours, then it might happen regularly for the same.

    I have tried or checked:
    Cleaning the mouse, changing the mousepad, adjusting ALL of the mouse related preferences and settings in OSX (including the settings in the Logitech panel in System Preferences), switching to the other Thunderbolt port, rebooting, mouse batteries, a different workspace, cable connections to the display, a different display, using a different 'known good' M510 mouse, and shouting.

    I read about and tried the Quartz 2D Extreme Enabled setting. Apparently this is rather old and I'm not sure if it's even relevant. I noticed some improvement, but I'm not sure if it's too early to tell since I did this yesterday.

    Opinions/Suggestions/Advice welcome! This is such a frustrating thing to deal with...
  14. macrumors newbie

    Mar 31, 2015
    It seems that this is a 10.10.3 issue this time. Google is starting to show a lot of recent posts about this. I have a Macbook Pro 17" (early 2011) with a WD Black2 Fusion Drive, 16gb ram and an upgraded BT4 airport chip. Needless to say, MY COMPUTER DOESN'T LAG. But I've been having problems ever since I updated to the latest version of OS X. I'm pretty sure it's just a software (driver) glitch.

    I've noticed that under the mouse preference pane, my mouse tracking has been reset to "slow" (like the slowest possible) as of the upgrade. I've changed it to what I want and it seems to be a bit better. Time will tell if it actually fixed it or if it's just placebo, but maybe we can all try that for not (those of us with 10.10.3) and see if that's a legitimate fix this time?

    My optical sensor is spotless and the batteries are perfectly contacting, so I think either this preference pane reset or the driver are really the issue at play here.
  15. macrumors 6502


    Jul 8, 2011
    I believe this thread is also about the same issue. I offered some thought on it based on my experience.
  16. macrumors newbie

    Apr 15, 2015
    I found a fix that actually works. Get a cheap 4 port USB hub (~ $7 on Amazon) and plug the mouse's wireless receiver into that instead of directly into the Mac. The mouse has worked perfectly ever since.
  17. macrumors member

    Nov 3, 2013
    A workaround that works for me and a lot of people:
    Disable Handoff in General settings on all acoounts on your Mac and reboot.
  18. macrumors 6502


    Feb 5, 2015
    I had mouse issues on Yosemite, but I haven't encountered it on El Capitan. So, my advice to people having problems is wait for the next OS.

Share This Page