Moved to Android, iPhone still receives iMessages

Discussion in 'Alternatives to iOS and iOS Devices' started by RossMacca, Jul 30, 2012.

  1. macrumors member

    Joined:
    Mar 31, 2009
    #1
    I recently got a Galaxy Nexus (amazing, by the way), but I've came across an issue. Some times when someone with an iPhone tries to text me (I have the same number), it goes to my iPhone and iPad via iMessage (and wifi), and nothing reaches the Nexus.

    Any ideas why this happens?
     
  2. macrumors 68000

    Joined:
    Aug 15, 2010
    Location:
    Southern California
    #2
    Go to settings and turn off imessage on your iOS devices.
     
  3. macrumors 6502

    Joined:
    Aug 1, 2010
    #3
    I just did the same thing and had some issues at first with iMessages and texts. My solution was to keep an email address for iMessages and change "Receive At" to the email address. That way you can still use iMessage and text from your Galaxy Nexus.
     
  4. macrumors 65816

    Joined:
    Dec 4, 2009
    #4
    Been there, done that, here is the solution:

    1) First step, turn off iMessages on your iPhone if you still have it.

    2) When your friends whom you used to iMessage to sends you a message, have them touch and hold the message that shows in blue (for them) until the option "send as text message" shows up and have them select and resend it as text. Once this is done once, it should always follow up as a text for them.

    3) if the above fails, go to your apple account and remove the phone as one of your supported devices and then repeat step 2.

    Step 1&2 worked for me.
     

Share This Page