Movies for iPod don't have sound

Discussion in 'iPod' started by mulze22, Nov 1, 2005.

  1. macrumors regular

    Joined:
    Jul 25, 2005
    Location:
    Up Nort
    #1
    I have used all types of programs from ffmpegx, quicktime and somebody's own program enpod and the movie will play fine but it doesn't give me sound. I have tried to play it in iTunes but nothing I seem to do works. You guys gotta help me. Oh and if this helps I'm encoding on a 455mhz AGP Graphics Powermac G4.
     
  2. macrumors 601

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #2
    What are you trying to do? Are you converting a movie from one format to mpg4 or something?

    Anyways, it kinda sounds like you're trying to convert a mpg1 or mpg2 file. In those cases, you'll need to demux the audio and video tracks and then recombine.

    do a forum search for "demux mpg video" or something. I normally use an application called MoreMissingTools to demux, iTunes to convert the audio and Quicktime Pro to combine the files.

    ft
     
  3. macrumors 6502a

    snowmoon

    Joined:
    Oct 6, 2005
    Location:
    Albany, NY
    #3
    Knowing the EXACT input file would be necessary to diagnose such problems. .avi, .rm, .mpg ... if it's .mpg is it mpeg-1, mpeg-2 if the other what codes and versions of the data.
     
  4. macrumors 65816

    MacTruck

    Joined:
    Jan 27, 2005
    Location:
    One Endless Loop
    #4
    I've been making ipod videos all week (just finished The Empire Strikes Back). Here is the deal. Some videos have the sound track mixed with the video, or something like that and won't convert the sound when making it for ipod. An easy way to find out if it will convert sound when converting to ipod is this. When you click File - Export you will see a drop down for Export. In there will be a bunch of choices. One is Movie to iPod (320x240). This is what you will used to make the ipod movie, but click on the one below it, "Movie to MPEG-4" then click options to the right of it. In the tabs click "Audio" and see if the drop downs are grayed out. If the are not grayed out then it will convert just fine, if they are you are screwed.
     
  5. macrumors 6502

    Konradx

    Joined:
    Oct 19, 2005
    Location:
    Toronto, Canada
    #5
    the problem i have is watching FF7 10 minutes in it looses sound..i turn it off..turn it back on later..same scene i get music back..10 minutes later no sound...getting annoying
     
  6. macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #6
    how do you use MoreMissingTools to demux, or split the video and audio? i downloaded this program, but i couldn't figure it out
     
  7. macrumors 6502a

    drater

    Joined:
    Oct 6, 2005
    Location:
    Boston, MA
    #7
    you know what i've been using for my .avi, MPEG Streamclip. It really is pretty easy, and its pretty fast. I've tried enpod, isquint and quicktime (talk about slow) and some of them worked for me, but seriously, this one is great so far. A 170mb .avi file takes about 30 minutes or so to switch. I suggest checking it out. http://www.alfanet.it/squared5/mpegstreamclip.html
    What I do is I open the program, file>open files> "choose file"
    then: File>Export to MPEG-4> here a screen will pop up, just click the "ipod" button on the top right, then ok. I suggest closing the "preview" screen cause it just looks stupid. And wait, show status and it moves pretty fast.
     
  8. macrumors 601

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #8
    I haven't used MMT in a long time, so this is all by memory. When you open the application, there should be a window with about 8 boxes. One of the box is labelled "demux" or something. Follow the prompts and select the video file that you want to split. A terminal window will open up. When all is done, in the same path as the original video file, you'll see two new files named "chunk". One's a .m1v and the other is a .m1a. I think.
     

Share This Page