Moving iTunes Library to NEW External

Discussion in 'Mac Applications and Mac App Store' started by panda bear, Jan 2, 2013.

  1. panda bear, Jan 2, 2013
    Last edited: Jan 2, 2013

    macrumors 68000

    panda bear

    Joined:
    Apr 5, 2010
    #1
    So I had all my iTunes files on an external hard drive called "iomega".

    This includes my manually organized music files as well as my library.itl files and all the associated iTunes files.

    The drive started giving me some problems, so I purchased a new external, which i've just named "External".

    I then moved everything from iomega to External and pointed iTunes to the library file on the new external.

    Now, I get the exclamation points next to the music files when I try to play them, because iTunes can't locate the file.

    I know that this is because the path to the files previously pointed to iomega and I now need it to point to External.

    Is there a way to just change that part of the path or do I need to just start my iTunes library over?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
  3. panda bear, Jan 2, 2013
    Last edited: Jan 2, 2013

    thread starter macrumors 68000

    panda bear

    Joined:
    Apr 5, 2010
    #3
    That would have iTunes organize my library, then.. correct?

    I asked a friend via AIM and they helped me with the problem.

    He gave me two solutions:

    1. Simply rename the new hard drive and make the name the same as the old one. Which I didn't really want to do, since the old external was named iomega and the new one is a WD and i'm weird..

    or

    2. Open the library.xml file in textedit and replace "iomega" with "External" and just hit "all" and it would replace every instance of iomega with External, therefore fixing my library problems.

    This is the solution I chose and it took literally 30 seconds.

    Thanks, FRED :)

    EDIT:

    Okay, the second option WAS working.. but I have since restarted my computer and it is no longer working :(
     
  4. matt56037, Jan 2, 2013
    Last edited: Jan 2, 2013

    macrumors newbie

    Joined:
    Feb 23, 2011
    #4
    First, have you tried just renaming your external to "iomega?" Maybe you don't want it to be named iomega but if it saves you the hassle it might be worth it.

    If not, you need to edit "iTunes Music Library.xml," not "iTunes Library.itl." I'm not sure of a good text editor on Mac; maybe TextEdit will get the job done but maybe it will crash (my xml file is over 15 MB which is huge for a text file).

    Copy and paste your "iTunes Music Library.xml" to somewhere else so you have a backup in case something goes wrong. Then open one of the copies and replace every instance of \iomega\ituneslibrary\ with \external\ituneslibrary\ or something to that effect. Just read the first few instances on the xml file to get an idea of where it's currently pointing to, and where you want it to point to. Depending on how you have your music files arranged (the ones that iTunes doesn't organize for you), this might not work. If it doesn't then just consolidate your library as the earlier poster said.

    EDIT: LOL I'm here for 5 minutes writing this up, and sure enough you already found this out 3 minutes earlier. What happens when you reboot? Exclamation points still? On every single song?

    EDIT2: Wow I'm an idiot. I didn't even read your second post or the "post resolved" thing. That's just embarrassing. But I can still try to help you.
     
  5. thread starter macrumors 68000

    panda bear

    Joined:
    Apr 5, 2010
    #5
    Haha, it's okay.. I prematurely updated the thread a couple times thinking things were peachy. Not quite sure why it worked and then didn't once I restarted..

    I did just kind of "give up" and rename the new external to iomega.

    I tried editing the xml file and doing all that and it cleared my whole library. I ended up re-copying the files from the old hard drive and re-started with the iomega library.

    I guess all my future hard drives will be named iomega from now on :(

    Thank you for the help!
     

Share This Page