moving mailboxes to other accounts

Discussion in 'Mac Basics and Help' started by Indo, Jul 22, 2005.

  1. Indo macrumors member

    Joined:
    Apr 2, 2005
    Location:
    Northern, VA
    #1
    how would one move a mailbox and all its contents from Apple's mail program from one user to another and have all the contents loaded up on that other account.

    don't know if this makes any difference but it's going from an admin account to a non admin one.

    thanks for any help.

    -Indo
     
  2. cardiac dave macrumors regular

    cardiac dave

    Joined:
    Jun 23, 2005
    Location:
    iToronto
    #2
    I'll answer your question, then follow up with one of my own - because I'm one step ahead of you, but with a follow-up problem...

    Navigate to your yourusername/Library/Mail directory and copy that entire directory to the same directory on the new machine.

    (I went this route when moving settings from my old iBook to the new iMac... as I didn't want to copy absolutely everything over...)

    Open mail on the new machine and you'll have all your current mailboxes, messages and server settings all set-up on the new system.

    Worked for me.... so far... except my problem now:

    I have to manually enter all the account passwords each time that I restart Mail. I use the checkboxes for 'remember in keychain' but my passwords are not being remembered. (They'll be remembered as long as mail is running, but not after)

    Someone please help! I'm going nuts having to retype DJEY4557, JKHU3443, QQBD9008 and apple each time I enter Mail. (not my real passwords....)

    I've done the standard 'repair permissions' and used Cocktail to run all the Chrons. This is my brand-spankin' new iMac G5 and this is my only gripe so far.
     
  3. cardiac dave macrumors regular

    cardiac dave

    Joined:
    Jun 23, 2005
    Location:
    iToronto
    #3
    Additional:

    ran keychain repair utility - no problems found,... no joy

    of the four accounts set up in Mail only the .mac account remembers it's password

    The Gmail and 2 private POP3 accounts do not remember their passwords.
     
  4. Indo thread starter macrumors member

    Joined:
    Apr 2, 2005
    Location:
    Northern, VA
    #4
    addressing your problem

    open the mail app, then go to Preferences > Accounts. in there click on each account and make sure in the account info the password for the incoming mail server is filled out. also if you do not want to enter your password when sending an email, in the same account info section click server settings under where the outgoing mail server is, and make sure you fill out the password.

    do the same for all the accounts and i think you should be fine. the same problem happened to me and i searched around and this was my solution.

    oh btw it's just moving to a new account not machine so i'll just put the mail stuff in the public folder? i'll try that.

    hope i helped and thanks for the help.

    -Indo
     
  5. Indo thread starter macrumors member

    Joined:
    Apr 2, 2005
    Location:
    Northern, VA
    #5
    well that didn't exactly work, i moved the mail folder from this account to the new one in the username > library since there was no folder there currently. i opened mail and it took me through all this set up stuff, which i didn't exactly expect or want to do.

    was this supposed to happen?

    -Indo
     
  6. cardiac dave macrumors regular

    cardiac dave

    Joined:
    Jun 23, 2005
    Location:
    iToronto
    #6
    errr.... sorry. Worked for me, just did it last night. I wonder if my account information was transferred in first as part of the .mac sync function. Copying that library over allowed me to keep the 4 mail folders and all their contents. All the account details remained the same as well.

    The only issue I'm having is that the .mac account is the only one that remembers its password.

    Is your mail working now? What's working and what isnt?
     
  7. Indo thread starter macrumors member

    Joined:
    Apr 2, 2005
    Location:
    Northern, VA
    #7
    well i haven't exactly gone through and entered the account info because i assumed it would just open up with all the mailboxes there. since this is the first time opening mail on the other account all it will let me do is set up.

    did my advice help any?

    -Indo
     
  8. Billicus macrumors 6502a

    Billicus

    Joined:
    Apr 3, 2002
    Location:
    Charles City, Iowa
    #8
    If there isn't already a Mail folder in ~/Library/ then go ahead and make one and place your contents from your old Mail folder inside. Or just copy the entire ~/Library/Mail over to your new User Account.

    I did this recently as well and I also moved ~/Library/Preferences/com.apple.mail.plist from my old account to this same location in the new account and everything worked perfectly.

    Hope this helps. :D
     
  9. cardiac dave macrumors regular

    cardiac dave

    Joined:
    Jun 23, 2005
    Location:
    iToronto
    #9
    the plist file(s) are the password files, right? I can just delete them, then go back and re-enter the passwords hopefully?

    I'll give that a shot and see what happens

    .... No joy.
     
  10. Indo thread starter macrumors member

    Joined:
    Apr 2, 2005
    Location:
    Northern, VA
    #10
    did you have to change any permissions on folders?

    -Indo
     
  11. Indo thread starter macrumors member

    Joined:
    Apr 2, 2005
    Location:
    Northern, VA
    #11
    alright i moved the folder and plist file and changed the permissions and moved them to the new account and opened mail and everything was fine, but, it says there is something wrong with the outgoing mail server or something like that. i keep going in the account preferences and changing the settings but same error keeps happening.

    to my knowledge there isn't anything wrong w/ the server because on this account i can send and receive mail perfectly fine.

    -Indo
     
  12. Billicus macrumors 6502a

    Billicus

    Joined:
    Apr 3, 2002
    Location:
    Charles City, Iowa
    #12
    What error does it give about the outgoing mail server?
     
  13. Indo thread starter macrumors member

    Joined:
    Apr 2, 2005
    Location:
    Northern, VA
    #13
    ah crap i deleted that entire account, so i will remake it and try again.

    -Indo
     

Share This Page