MP+10.4.8 failing to open .DMG files : Help?

Discussion in 'macOS' started by Macinposh, Nov 29, 2006.

  1. Macinposh macrumors 6502a

    Joined:
    Jun 7, 2006
    Location:
    Kreplakistan
    #1
    So.

    After updating to 10.4.8 from 10.4.7 the .DMG files wont open anymore.


    Like none of the loaded (yes,os x based, yes working files, yes...) dmg:s just wont open.
    Tried to load the stuffit,but as that is a dmg file too..no help.

    Nothing happens when i drag the files straight to disk image opener either.

    If i click on a dmg file, nothing happens for few minutes, then a "Warning" box appears with a message :

    "The following disk images failed to mount"

    image - reason
    stuffitexpander11.0.1 device not configured
    missing sync device not configured


    .




    Anyone?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    If you select the DMG and then press COMMAND-I to summon the Get Info page, does it say they're being opened with DiskImageMounter as the default app? It sounds like Stuffit is trying to mount them, but really you don't want this. If Stuffit is selected, then reselect DiskImageMounter and click on Change All to ensure other DMGs open with this app. :)

    Alternatively, try opening/mounting them in Disk Utility, an app within the Utilities folder. :)
     
  3. Macinposh thread starter macrumors 6502a

    Joined:
    Jun 7, 2006
    Location:
    Kreplakistan
    #3
    Yo.

    So first there was diskimage.

    Which caused that nothing happened.

    Then i tried to download stuffit,but as that was a DMG too, nothing happened either.


    So sorry, nada.

    And when i try to open with disk utility, there is just nothing...



    WHOOAH!!!


    Now as i type, the diskutility opened the file!!!
    I had tried that before few times (with OPEN) command to no avail!!

    Thanks for your magic touch, you Mad Jew!
    But it still leaves me wondering why the hell the diskimagemounter doesnt work...
    :confused:
     
  4. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
  5. Macinposh thread starter macrumors 6502a

    Joined:
    Jun 7, 2006
    Location:
    Kreplakistan
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Check to see if it works in a different user account. There are a few bugs that stop DiskImageMounter from working, but most of them are easy to fix. :)
     
  7. Macinposh thread starter macrumors 6502a

    Joined:
    Jun 7, 2006
    Location:
    Kreplakistan
    #7
    Sorted.



    First the Diskutility started to work (didnt work on the first 5 tries) and then when you used the "open with a different program" option, and THEN choose the DIM, things started to work again. Bit by bit.:confused:

    Now it unpacks .DMGs just fine.

    Weird.


    Thx guys.
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    Awesome work mate. Post back if it plays up again. :)
     

Share This Page