MPEG streamclip won't find all audio tracks

Discussion in 'Digital Video' started by deanna1ynne, Nov 15, 2012.

  1. macrumors newbie

    Apr 9, 2011
    I have some m4v files that I ripped from DVDs using handbrake. The default language track on the files is German, but they do also include the option to play in English. When I open the movie in VLC or other apps, it automatically plays German, and it's the German audio that I'd like to extract.

    However, when I try to watch the movie or export the audio using streamclip, it always plays/exports the English. I've read that you can change this in the "Audio PID" drop down menu, but when I click the drop down menu, there is nothing available to choose (the menus are just empty). I'm running max os 10.5.8. What am I missing or doing wrong?

    Thanks for any tips!!
  2. thread starter macrumors newbie

    Apr 9, 2011
    Update: If I use handbrake to rip a movie and only choose one audio track (the German one), then streamclip does, in fact, extract the German audio track. But I'd really rather have the movie on my computer with both tracks, since my husband does not speak German.

    Is there a way to force it to give me a list of audio tracks, without the PID pull-down menu (that only says "0")? It's strange to me that it automatically plays in German in VLC, quicktime, itunes, etc., but streamclip won't even give me the *option* to play it in German, as far as I can tell.
  3. WRP
    macrumors 6502a

    Jul 20, 2011
    Did you check your preferences? There is a checkbox for "convert only one audio track." I never use streamlclip for this purpose so I have no clue, but maybe check that out???

    Also something to think about, do you open the file via the "open" selections inside streamclip or do you Right-click it and choose to open in streamclip.

    And again, since I don't deal with ripping DVD's, is it possible to open the DVD in streamclip and export from there instead of the 2 process? Are they copy protected?

Share This Page