MPEG to AVI conversion?

Discussion in 'Mac Apps and Mac App Store' started by fanofdool, Sep 7, 2004.

  1. fanofdool macrumors newbie

    Joined:
    Jun 14, 2004
    #1
    Okay, here's the deal.

    I have a large MPEG I cannot open in Quicktime, but I *can* open it in mPlayer. I need it in AVI format.

    What are my options?

    P.S. I saw the other MPG to AVI thread, but it dealt with converting it from MPEG to AVI within quicktime: Something I can't do if I can't *open* the MPEG in Quicktime.
     
  2. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    Location:
    Thunder Bay, ON
    #2
    Use ffmpegX, but it all depends on what you want to do with it - avi is just a container - what codec must it be encoded with to be useful?
     
  3. ChrisFromCanada macrumors 65816

    ChrisFromCanada

    Joined:
    May 3, 2004
    Location:
    Hamilton, Ontario (CANADA)
    #3
    I second that, even though it is somewhat difficult to install.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Is it an MPEG 2 file? Installing Apple's MPEG 2 codec will allow QuickTime to open it, and you will then be able to use the Export function in QuickTime Player.
     
  5. fanofdool thread starter macrumors newbie

    Joined:
    Jun 14, 2004
    #5
    I need to edit the file (splitting, omitting some stuff) and burn it to a DVD.

    <<Is it an MPEG 2 file? Installing Apple's MPEG 2 codec will allow QuickTime to open it, and you will then be able to use the Export function in QuickTime Player.>>

    I don't know, but it won't open in QT and I do have the Apple MPEG2 codec.
     
  6. fanofdool thread starter macrumors newbie

    Joined:
    Jun 14, 2004
    #6
    Okay, I installed ffmpeg but for some reason it won't work. Here're the properties of my video:

    Mpeg 2 Program Stream File [Video/Audio]
    Muxrate: 2.67 Mbps
    Estimated Duration: 40:00.71s
    Aspect ratio 1/1 (VGA)
    Interlaced, chroma format: 4:2:0
    Size [480 x 576] 25.00 fps 2.56 Mbps
    Audio: Mpeg 1 layer 2
    224 kbps 44100 Hz
    Stereo, no emphasis

    When I click "play" it plays fine. But when I try to encode it as any Xvid, any MPEG2.. it says "Error when opening file."

    Any ideas?
     
  7. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    Location:
    Thunder Bay, ON
    #7
  8. fanofdool thread starter macrumors newbie

    Joined:
    Jun 14, 2004
    #8
    Encoding started on Sun Sep 12 21:46:24 PDT 2004
    ## Component Manager: attempting to find symbols in a component alias of type (eat /IPIX/iPmh)
    ## Component Manager: attempting to find symbols in a component alias of type (imdc/MP42/MSFT)
    ## Component Manager: attempting to find symbols in a component alias of type (mhlr/iPmh/iPXC)
    usage: movtoy4m -w width -h height -F a:b -a a:b [-s] [-f] [-o ppm/y4m] movie.mov
    example: movtoy4m -w 352 -h 288 -F 25:1 -a 4:3 pal_normal.mov
    example: movtoy4m -w 352 -h 240 -F 30000:1001 -a 16:9 ntsc_wide.mov
    pipe:: Error while opening file

    And it's a PAL SVCD source, yea. I wanted to burn it to an NTSC DVD.
     

Share This Page