Multiple Blank CDs Shown in Finder (?)

Discussion in 'macOS' started by ~Shard~, Jul 23, 2005.

  1. ~Shard~ macrumors P6

    ~Shard~

    Joined:
    Jun 4, 2003
    Location:
    1123.6536.5321
    #1
    It isn't a huge deal, but I always wondered why when I insert a blank CD/DVD into my SuperDrive prior to burning something, multiple instances of the blank disc appear in Finder.

    When I initially insert the disc, only one appears, which is fine. But then when I open up Toast, another sometimes appears. Then, when I click the Burn button and the Write dialog box opens, yet another blank CD appears in Finder!

    Lastly, after I burn the disc, the finished disc is properly represented in Finder, but the Blank ones still show as well. In fact, when I eject the disc, Finder doesn't get rid of the duplicate Blanks and I have to specifically click on each "ghost disc" and eject it for them to go away!

    Any ideas why this happens and why Apple hasn't fixed this in any of the software updates? Seems like a rather simple issue to resolve... Or is this simply a setting change I can make somewhere to prevent this from happening?
     
  2. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #2
    Duff-Man says...I have not seen this happen on either my G5 or Powerbook. Does the behaviour change at all if you change the pref for "what to do when a blank cd/dvd is inserted?" ....oh yeah!
     
  3. ~Shard~ thread starter macrumors P6

    ~Shard~

    Joined:
    Jun 4, 2003
    Location:
    1123.6536.5321
    #3
    The only setting I know of is the one where it says, "When a CD/DVD is inserted, do the following:" and then it lists a few "open with" type of options. I've set these to ignore, so I'll see what happens next time.

    Thanks for the advice - that was a simple thing I never really thought of. ;)
     
  4. neocell macrumors 65816

    neocell

    Joined:
    May 23, 2005
    Location:
    Great White North
    #4
    I had this happen once before. I always get the option when I put a blank disc in and one time I hit ok instead of ignore (so I got an icon on the desktop). Well I was going to burn with toast so I set it up and then when I clicked to start the burn the popup window opened again and asked me what I wanted to do with the disk and this time I clicked ignore but the icon stayed on the desktop and like you said I had to eject it to get rid of the ghost disk. Now I just alway click ignore for all the times the popup window opens (why is it always more than once??)
     
  5. ~Shard~ thread starter macrumors P6

    ~Shard~

    Joined:
    Jun 4, 2003
    Location:
    1123.6536.5321
    #5
    Glad to hear someone else has experienced this before. I'll play around with the Ignore options and see if that helps.

    Thanks for the feedback guys. :cool:
     
  6. tangerineyum macrumors 6502

    Joined:
    Feb 16, 2005
    Location:
    Ontario, CA
    #6
    this happen to me too with my 1ghz emac with panther. But it only happens when i burn something using toast or popcorn. I also noticed that it only happens when trying to make data or movie dvds.
     
  7. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #7
    Oh good- I'm not the only one. This happens to me a lot. I don't really like the way the preference thing that pops up is set up. I end up with two or three cd icons that I have to 'eject' after I make a cd.

    Edit: That is, on my Panther system. Haven't noticed it in Tiger.
     
  8. ~Shard~ thread starter macrumors P6

    ~Shard~

    Joined:
    Jun 4, 2003
    Location:
    1123.6536.5321
    #8
    Yes, to clarify, I am still on Panther and don't have Tiger. I burned a disc this morning and didn't have any of the same issues, so I think changing those settings to "Ignore" in the Preferences did the trick.
     

Share This Page