Multiple speakers, sound stops but music still showing as playing in iTunes

Discussion in 'Mac Apps and Mac App Store' started by fb6668, Nov 24, 2012.

  1. macrumors newbie

    Apr 4, 2011
    My setup:
    iMac with iTunes 10.7 in home office
    Time Capsule as wifi router (connected by ethernet to iMac)
    AppleTV2 in living room
    Airport Express connected to Bose speakers in kitchen

    This is a strange one. When playing music from my iTunes library just on my computer, it works absolutely fine.
    However, if I play to any other speakers, either individually (eg just on AppleTV2) or as multiple speakers, then after an indeterminate amount of time, the music will stop playing. It always stops between tracks, so one song finishes and the next never starts. If I look at iTunes on the iMac, the progress bar of the song is still moving, as if the song is playing. If I skip back to the beginning of the track, it will play to all chosen speakers again, until it decides to repeat this behaviour.
    Sometimes this may be a matter of a few tracks, sometimes it will be a few hours.
    One time, I went to bed having forgotten that it was still "playing" silently and it actually turned back on (and woke me up) in the early hours of the morning.
    It doesn't matter how i start the music playing, whether through my iMac directly, through the AppleTV or through the remote app on my iPhone, the same behaviour always occurs.
    I think the weirdest thing is that the sound also stops being played through my computer's own speakers, which makes me think that it's not a network problem?

    Has anyone else come across this and have a solution for it?



Share This Page