Multiple text threads from same person? Why?

Discussion in 'iOS 5 and earlier' started by miamialley, Oct 13, 2011.

  1. macrumors 68020

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    California
    #1
    My friend with an iPhone 4 sends me texts only from his iPhone 4. Some go to my iPhone and some go to my iPad. He's sending them all to my phone number. Also, it creates multiple threads on my phone and iPad. So, from the same person, I'll have two different threads of texts from the same phone.

    Is this a glitch or am I missing something?
     
  2. macrumors member

    Joined:
    Mar 15, 2010
    Location:
    Massachusetts
    #2
    I had something similar happen on my iPhone where I had a text message thread, then a new thread when the person upgraded to iOS 5 and things were going through iMessage. Her email address popped up instead of her name. I deleted the old thread, and now things seem to be coming under one thread.

    May be just an early glitch with iMessage?
     
  3. thread starter macrumors 68020

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    California
    #3
    We are both on ios 5 and it's still happening.
     
  4. macrumors newbie

    Joined:
    Jan 9, 2010
    #4
  5. thread starter macrumors 68020

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    California
    #5
    Right now it's creating a thread when my girlfriend texts me from her iPhone and a separate thread when she texts from her iPad. But not all messages go to both devices. :confused:
     
  6. macrumors 6502

    Joined:
    Mar 14, 2011
    #6
    You should both try this:

    * On your iPads, set "Receive At" as your Apple ID e-mail address

    * On your iPhones, set "Receive At" as both your Apple ID and your phone number

    * On your iPhones, set "Caller ID" (under Messages -> Receive At -> Caller ID) to your Apple ID

    * On your iPhones, make sure "Send As SMS" is ON (so that if iMessage fails for whatever reason, your message is still sent as SMS)

    * Add your Apple IDs to eachother's contact information

    * When sending messages target the recipient's Apple ID, not their phone number.
     
  7. thread starter macrumors 68020

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    California
    #7
    We've done all that. I don't get it.
     
  8. macrumors newbie

    Joined:
    Jan 9, 2010
    #8
    i know why this happens, it's very frustrating. this is because the iPad does not have a phone number. when you send messages via that it's from an email address so it will appear in a separate thread. if you look in the settings only the iPhone has the option to receive iMessages at your phone number.

    iPhone-->iPhone uses the phone number, it's phone number-->phone number
    iPad-->iPhone is email address-->phone
     
  9. macrumors 6502

    Joined:
    Mar 14, 2011
    #9
    In that case I'm stymied as well :/

    This is exactly why you would select your email address as the "Caller ID" on your iPhone - that way when you're sending an iMessage from your iPhone, it tells the recipient "Hi, I'm (EMAIL)!" rather than "Hi, I'm (PHONE NUMBER)!". Since the iPad also identifies with that email address when sending, it "appears" like the messages are coming from one and the same sender.

    For some reason this isn't working for the OP.
     
  10. macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #10
    Same problem here. One unified thread on MY iPhone (regardless of if it came in as an SMS or an iMessage), but two different threads on my Wife's phone depending on if it was sent via SMS or iMessage. And because it's two different threads, they're not all going to her iPad.

    Frustrating.
     
  11. macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #11
    This. You should set caller ID on all iOS devices to the same email address. If anyone wants more info, see: http://howto.cnet.com/8301-11310_39-20107458-285/how-to-get-started-with-imessage/
     
  12. macrumors 6502

    Joined:
    Jul 14, 2008
    #12
    While this may be the easiest workaround, the real solution is of course to group all messages from one contact, rather than one phone number/email address, together. I have a friend who recently got a new phone number. I saved the old one in his contact entry, but I now have two different conversations going.

    I requested this in one of the earliest beta's for iOS 5, but they didn't do anything with it, unfortunately...
     
  13. thread starter macrumors 68020

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    California
    #13
    But how does that help this issue? I mean, if my friend sends me a message from her iPad and then from her iPhone, then they could still show up in different threads on my devices if she doesn't have the caller ID set up as you describe. Right?
     
  14. macrumors 65816

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #14
    I find the caller ID thing to be kind of annoying. It should just reply back with the email it was sent to. I have a couple of emails under iMessage but ppl get confused when I reply back and it's an email address they don't have. I need to keep my personal separate from my work email but now everyone will see the same email.
     
  15. thread starter macrumors 68020

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    California
    #15
  16. macrumors 6502

    Joined:
    Mar 14, 2011
    #16
    Sorry, I'm confused :/ I explained why both of you should set your e-mail addresses as the Caller ID and then target eachother's e-mail address when messaging, regardless if you're using your iPhones or iPads. Choosing not to do so will of course continue to cause problems with separate threads and whatnot.

    Though, to be frank, it seems that even if you set everything up as described you might still run into problems. Judging by posts on this forum iMessage is anything but obvious :p
     
  17. thread starter macrumors 68020

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    California
    #17
    I've had the caller ID set up how you described since day one and still have problems. (As I have already said)
     

Share This Page