MX510 won't work with expose

Discussion in 'Macintosh Computers' started by homerjward, Dec 26, 2004.

  1. macrumors 68030


    ok. i got an mx510 for my new emac because i knew i would get sick of a 1-button mouse. it worked great at first, but then i had to reboot to install 10.3.7 and some other things and it didn't work in Safari. i thought, okay, i'll just install the logitech control center dealie, but that stopped it working in expose, and the application switch button just does cmd+tab, not show all windows like i had programmed. it does work in safari though. right now i'm using the plain old apple mouse because if the actual mouse is broken i don't want to use it too much before returning it. if i do have to return it or whatever it was ordered from newegg...any help would be much appreciated. i uninstalled teh logitech control center and trashed the preferences file from the library. i haven't tried rebooting yet, but i did fiddle with the expose settings in system preferences.
  2. macrumors 68030


    well, turns out a reboot fixed it. i should have tried that first thing...
  3. macrumors 68030


    sorry to keep bumping this thread, but i thought the reboot had cured it. then, i discovered it works in expose but not in safari! i tried installing the logitech control center again but that made it work just in safari, then fiddled with some settings then got rid of it and trashed teh prefs and rebooted for like the 5th time inside of an hour. i dl'ed usb overdrive and set the forward/back buttons to work as such in safari but no dice. it works in expose though. am i stuck with one or the other?
  4. macrumors P6


    Hmm, that's not good news. I actually just received an MX510 for Xmas but haven't had a chance to hook it up yet on my iMac. I probably will in the next couple of days, so if I run into the same problem I'll let you know. Hopefully it's not a general issue with the mouse, and I kind of doubt it is, or else I think I would have come across that when I researched it. I'll try playing around with it when I get it hooked up and if anything comes to mind on why yours might not be working, I''ll letcha know...

Share This Page