1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

My AppleTV just died :-( Sympathy please

Discussion in 'Apple TV and Home Theater' started by uberjason, Sep 12, 2009.

  1. macrumors member

    uberjason

    #1
    I noticed it wasn't syncing in itunes. Turned on the TV and the appletv amber light was blinking and the appletv was rebooting over and over again.

    Unplugged it, waited about 5 minutes.

    Plugged back in, did a factory restore.

    Restored fine to Version 1.0 - iTunes syncing, no problem. (just a few shows).

    Back to appletv to do upgrade to 2.4 software. AppleTV display shows menu, but keeps flashing the silver apple logo, cycles about every 1.2 seconds.

    Unplugged again.

    Plugged back in, Appletv boots fine, but when accessing the menu, starts flashing silver apple again. Cannot do anything in the menu.

    Unplugged and read it last rites.
    :(


    Off to apple store tomorrow.
     
  2. macrumors 68040

    ntrigue

    #2
    I've grown to hate my Apple TV. I spend more time resetting/restoring/closing iTunes/resyncing/resharing than I ever do watching it.
     
  3. macrumors 604

    Cave Man

    #3
    It sounds like your hard drive is failing. If you're prepared to spend a half a day on it, it might be worth the diagnosis. Essentially, you'll need to pull the drive and connect it to a Mac and then do a hardware test. If it fails, then you've isolated the problem.
     
  4. macrumors member

    uberjason

    #4
    Thanks Caveman! I was just speaking to the apple genius about it. Of course apple is 90% the price of a new one to fix it. However, I am thinking of just replacing the drive myself - following all the how-to's on the forum of course.
     
  5. macrumors newbie

    #5
    Just in case you need a confidence booster - I replaced the drive in my aTV earlier this year - bringing the poor thing back from the dead, don't remember having any problems!. I love my aTV and use it everyday!
     
  6. macrumors member

    uberjason

    #6
    Thanks EvilMatty! The problem is I don't have an image of the original drive unless I crack open a newly purchased appletv. I use to have a dmg of the original that was making the rounds a few years back, but it has been long deleted. If I can find that image in my backups, I will attempt to install. Did you have an image of yours before it died?
     
  7. macrumors regular

    #7
    Interesting - I have the very same problem so it would seem...

    After reading this thread I went over to my AppleTV and when the screens were cycling between the menu and the silver Apple I could hear the drive seeking around, so it could well be a HDD that's on the way out.

    Consequently, I've opened my AppleTV and I'm currently trying to take a backup of the disk. I'm *sure* I have a spare (larger) HDD around here somewhere, so I may have the added benefit of more space when I restore onto the new disk....

    Currently using this guide: http://www.appletvhacks.net/2007/03/23/apple-tv-harddrive-upgrade-process/ (using the 'Long Method').
     
  8. macrumors newbie

    #8
    Interestingly when my aTV died I took it to an authorised Apple service centre that charged me £50 to even look at it.. They informed me that (as I had suspected) the HDD had died. However they refused to fix it for me as Apple had told them they were not allowed to repair it (there was no given reason for this - and Apple denied it when I contacted them directly). Anyway to cut a long story short the service centre recommended I took the slightly less than legal route and download an image from one of the torrent sites - which I did!

    Not sure if I'm allowed to give details of where to get the file so I'd better not, but I'm sure Google will be of help!
     
  9. macrumors 604

    Cave Man

    #9
    You should first diagnose the problem, then worry about the rest. ;)
     
  10. macrumors member

    #10
  11. macrumors 603

    TwinCities Dan

    #11
    I agree with Cave Man, it sounds like the drive is going. Get in there and crack her open. ;)
    I don't think it's and iTunes 9 problem, because mine works flawlessly with SL and iTunes 9.
    Let us know how it goes, if you can't fix it then pick up a new one.

    P.S. You have my sympathy, I'd be lost without my :apple:TV :(
     
  12. macrumors member

    uberjason

    #12
    I fixed it!

    It was a 1.0 bug with itunes 9

    See apple support discussion:

    http://discussions.apple.com/thread.jspa?threadID=2152096&tstart=0



    Basically, I had to disconnect all my wireless devices, shut off wi-fi on my APX, and use an ethernet cable to get it to start. Then used said ethernet cable to download the upgrade to 2.4, it has worked fine since.
     
  13. macrumors 603

    TwinCities Dan

    #13
    Good to hear you're back up and running, congrats! :cool:
     

Share This Page