My ATV2 no longer connects to iTunes?

Discussion in 'Apple TV and Home Theater' started by amitdoc2b, Jan 23, 2011.

  1. macrumors 6502a

    Feb 25, 2008
    Just the other day I was playing music videos from my iTunes on my ATV2. I have the latest iTunes & ATV2 software installed, home-sharing is on, WIFI network is always strong, every other feature on ATV2 is working, tried resetting, turning iTunes home-sharing on/off, etc.. Nothing seems to make the ATV2 recognize my iTunes account anymore? What's wrong with it and how can I fix it? I've had the ATV2 since October and never had any problems till now (and I don't jailbreak). Thanks a bunch.
  2. thread starter macrumors 6502a

    Feb 25, 2008
    Weird. I just tried testing the network connection and it failed. I needed to reenter my password. But when I checked the signal strength it said it was strong even though it wasn't even connected. Not sure why the password had to be reentered because I never reset my router or anything like that, all other wireless devices were working fine. Nonetheless, glad its working again.
  3. macrumors 68000


    Jan 9, 2011
    In front of uranus
    I have noticed from time to time, in my multi-ATV home, that a reset is needed. Simply unplugging the ATV, waiting a few seconds and then plugging back in. A hard reset, so to speak. Only issue is, you have to redo all the settings again (name, password, wi-fi network name, etc...), which is a PIA. I have no idea what causes this and it only happens ever now and then.

    Sounds like a similar issue to yours?

Share This Page