My desktop pictures preference pane quits on opening?

Discussion in 'General Mac Discussion' started by rhubarb, Jul 11, 2004.

  1. rhubarb macrumors newbie

    Joined:
    Jul 11, 2004
    #1
    My desktop pictures preference pane has started to quit on opening.
    I've tried setting up a new user account and the desktop picture prefs are OK in that account. Tried to copy pane and overwrite original pane but get message saying unmodifiable. Fairly new to OSX so struggling a bit. Please help!
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Try deleting this file and trying again: ~/Library/Preferences/com.apple.systempreferences.plist, where ~ is your user directory.
     
  3. rhubarb thread starter macrumors newbie

    Joined:
    Jul 11, 2004
    #3

    Tried deleting file 'com.apple.systempreferences.plist' as suggested and restarted but problem is still the same – any other suggestions. Thankyou.
     
  4. N10248 macrumors 6502a

    N10248

    Joined:
    Jun 11, 2004
    Location:
    Essex, U.K.
    #4
    Maybe one of the actual desktop pictues is currupt, and when it loads it as a thumbnail it causes it to crash, try removing any recently added pictures and then try it again (the "Pictures" folder in your home directory is always included and may have some corrupt image files in it).

    Bye
     
  5. rhubarb thread starter macrumors newbie

    Joined:
    Jul 11, 2004
    #5
    Have tried that, but alas still no result! Any other suggestions please.
    Thankyou
     
  6. HarbV7.0 macrumors newbie

    Joined:
    Jul 11, 2004
    #6
    Run repair permissions from Disk Utility and see if that helps.
     
  7. rhubarb thread starter macrumors newbie

    Joined:
    Jul 11, 2004
    #7
    Ran repair permissions with disk utility, but this did not solve it either! Sorry if this is getting really boring now but I like to get to the bottom of things. Anything else, cheers.
     
  8. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #8
    Duff-Man says...perhaps it is the com.apple.desktop.plist that is corrupted...try deleting that one....oh yeah!
     
  9. rhubarb thread starter macrumors newbie

    Joined:
    Jul 11, 2004
    #9
    Spot on man. That worked perfectly. Thankyou very much, you are the man.
     

Share This Page