My Ethernet went away

Discussion in 'Macintosh Computers' started by Veldek, Jul 5, 2004.

  1. macrumors 68000

    Veldek

    Joined:
    Mar 29, 2003
    Location:
    Germany
    #1
    I'm really frustrated. My brother gave me his old PC, so I wanted to network it with my Mac. I started yesterday and couldn't get it to work, went to sleep and wanted to try it again after getting home from work. Now, when I open the Network pref panel, there's no Ethernet option anymore. I'm pretty sure it's been there yesterday. I typed "ipconfig getifaddr en0" into Terminal yesterday to get my IP address. But when I do this today, I only get "get if addr en0 failed, (os/kern) failure". I have a feeling something went horribly wrong. Could anyone explain to me, what I can do?
     
  2. macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #2
    You should write ifconfig instead of ipconfig.
    don't know about the disappearing problem though. Sure about it? Hope you are not overlooking that there is a drop down menu in systemprefs-sharing-show.
     
  3. thread starter macrumors 68000

    Veldek

    Joined:
    Mar 29, 2003
    Location:
    Germany
    #3
    Should be ipconfig. I got that from the Mac-PC networking sticky from edesignuk. It worked yesterday, but not today.

    And you're right. In SysPrefs-Network-Show, Ethernet is still there, but it's not in the status window anymore, as it's been yesterday. That's what disturbs me. And when I select Ethernet from the Show menu, there's no IP address anymore, though there was one yesterday.

    What I forgot to mention and what could be useful information is, that when I wanted to wake the PC from sleep today, it didn't work, so I had to hard reset it.

    Edit: I found out that the Ethernet port on my Mac is all right. It seems the Ethernet port on the PC is (now) broken.
     
  4. thread starter macrumors 68000

    Veldek

    Joined:
    Mar 29, 2003
    Location:
    Germany
    #4
    Ok, I don't know why, but after a dozen (no joke or exaggeration) restarts, Ethernet is finally recognized again and I can share files, just like edesignuk wrote. But Internet Sharing still doesn't work. I checked the Sharing prefs more than twice but I can't figure out what I'm missing.
     
  5. macrumors 6502a

    Joined:
    Jun 8, 2004
    #5
    When sharing, make sure you not only select a connection to share from, but to share to. And make sure you select the right one to share to.
     
  6. thread starter macrumors 68000

    Veldek

    Joined:
    Mar 29, 2003
    Location:
    Germany
    #6
    I selected to share my Airport connection with computers connected over Ethernet, which is what I want to do. Am I missing something?
     
  7. macrumors 6502a

    Joined:
    Jun 8, 2004
    #7
    That should work, if not, then I don't know what you can do.
     
  8. thread starter macrumors 68000

    Veldek

    Joined:
    Mar 29, 2003
    Location:
    Germany

Share This Page