My homepage keeps redirecting to Google Pakistan

Discussion in 'OS X Mountain Lion (10.8)' started by kiddk1, Mar 20, 2013.

  1. macrumors regular

    Aug 16, 2009
    I have a macbook pro running the latest edition of mountain lion- my homepage was set to now it keeps redirecting to google pakistan, even if I type in in the address bar, it redirects to please advise

    Thank you
  2. macrumors 6502a

    Jun 20, 2007
    no cars, only boats

    It should force the .com and avoid the language/location redirect
  3. thread starter macrumors regular

    Aug 16, 2009
    That works temporarily, until the next reboot- then it happens again

    And now it wont connect online???
  4. macrumors 65816


    I am assuming you are in the U.S.
    Are you using a proxy or vpn?
  5. thread starter macrumors regular

    Aug 16, 2009
    Sorry, yes i am in the U.S, I have parallels 8 installed but it is currently off- what was weird is that it was not connecting to any ".com" addresses only .net or .org

    Also- i have sophos anti virus installed- when i run it- it runs for about 2-3 minutes then force closes???
  6. macrumors 603


    Get rid of Sophos AntiVirus, it can increase vulnerability.

    Mac Virus/Malware FAQ - Mac Guides

    You are on OS X, a virus scanner is not needed, it can also create problems, just uninstall that crap.
  7. thread starter macrumors regular

    Aug 16, 2009
    Thank you!!!! I will remove now and see what happens
  8. thread starter macrumors regular

    Aug 16, 2009
    what about spot flux? i have that installed also? I am a recent convert to mac and love it!!!
  9. macrumors 603


    Flux, Isn't that the auto dimming display App, if that's the case it's OK.
    Most Apps are OK, but some are not, a virus scanner is not really needed in OS X, but there are 2 Apps to which you should never install, MacKeeper and CleanMyMac, they can do more damage than good, the first one is also notorious for it's adds on the web.
  10. thread starter macrumors regular

    Aug 16, 2009
    Laptop is back online – still going to Google Pakistan – Now I am getting this message when I try to access Mac rumors from MacBook

    MacRumors cannot be accessed from your IP address. If you are using ONSPEED or a similar service that relies on proxies, change your settings so the service does not use a proxy for domain, or do not use the service while accessing MacRumors. That should restore your access. We apologize for the inconvenience, but we need to block certain IP addresses and proxy services in order to maintain our forums as an advertising-free and spam-free zone. If you are not using ONSPEED or a similar service, your MacRumors account and IP address may have been banned for breaking forum rules, or you may share an IP address with someone who was banned. If you think an IP block is in error, you can contact the administrators.
  11. macrumors 603


    That changes everything, if you use a proxy server and especially one which automatic chooses a new one there is no wonder you get something like that.
    I know Netshade (App) for instance can change proxies automatically or you set it manually, if you set a proxy server and it is located in Pakistan then your google thinks you are in Pakistan
  12. thread starter macrumors regular

    Aug 16, 2009
    How do I fix this?

    Odd thing is, I just put in my old hard drive-I cloned to a larger one a month ago- to see if it may be something in my system and it stil goes to google pakistan on my old drive- this drive does not have parallels installed on it

    also this problem is not happening on my 2 other pc's
  13. macrumors 6502a

    May 2, 2010
    East Maitland, NSW, AU
    Sounding more and more like a proxy on your end or at your ISP.

    Try setting your modem/router to use google or openDNS.
  14. macrumors 603


    Now, question, do you connect to the same internet connection with all the PC's, if not it might be the connection to your Laptop.

    If you did not install anything yourself you can check if you do have a proxy server setting on your Mac by going to System Preferences>Network>active network>****Advanced.proxies, if nothing is set there your provider might be the problem.
    ****= If you connect over a wireless connection choose Wi-FI, if wired choose Ethernet.

    It is also possible that the setting is in the Modem/Router but I doubt it, this should affect all PC's if you connect to the router with all the PC's.
    If you use a wireless connection is the wireless network sufficiently protected, if not someone might have hacked and changed the settings inside the Modem/Router.

    If you go on another network somewhere else, does it still do this or is it gone, if it's gone it points towards your network or the provider.
  15. thread starter macrumors regular

    Aug 16, 2009
    ok-no proxys are listed- things seem to be better-i put back my old HD as I stated earlier- went to google and it went to google pakistan-I typed in as stated and it went to the standard google home page and I have not had any issues since. I dont know if I installed anything on the other HD that could have caused the issue- I am going to clone the HD again and start over.
  16. macrumors newbie

    Mar 23, 2013
    Spotflux redirect

    Just turn off spotflux, go to google. realize your not in Pakistan anymore.
  17. thread starter macrumors regular

    Aug 16, 2009
    I removed spotflux, so far so good

Share This Page