My iMac won't stay asleep

Discussion in 'Mac Basics and Help' started by stringtheorist, Mar 17, 2010.

  1. macrumors regular

    Joined:
    Apr 1, 2008
    #1
    I put my iMac to sleep before I go to bed and it usually stays in that state until I get up. Lately something is waking it routinely during the night. I have attempted to fix this by following the suggestions in Mac Help but I still can't get to the bottom of it.
     
  2. Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    Southampton, UK
    #2
    It could be the Bluetooth Mouse. Have you tried turning the mouse off?
     
  3. macrumors newbie

    Joined:
    Nov 6, 2009
    Location:
    Hampshire, England
    #3
    Hi,
    My iMac used to do this, I found out because my parents came to stay & slept in the same room as my 27" imac, the bright screen kept waking them during the night.
    I turned off "wake for network access" in system preferences under Energy Saver, I unticked the box & all seems fine now.

    Hope this helps
     
  4. macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #4
    I never turn off my mouse. Is that something I should be doing anyway? batteries seem to be holding up quite nicely. That is one of the reasons I have left the mouse on, to test the battery life and so my system is always ready to work.
     
  5. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  6. Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    Southampton, UK
    #6
    Nope definitely not, I leave my on all the time just for ease of use and this is the way Apple intended it for use. I have just read reports that bluetooth mice sometimes cause the iMac to wake from sleep.
     
  7. macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #7
    Macs can wake from sleep due to:
    - Bluetooth activity
    - USB port ativity
    - Network Access

    All of these can be turned on/off in system preferences.
     

Share This Page