My iPhone's mail isn't working...please help.

Discussion in 'iPhone' started by MorganK, Jul 30, 2010.

  1. MorganK
    Expand Collapse
    macrumors regular

    Joined:
    Apr 13, 2010
    Location:
    Mobile, AL
    #1
    Since yesterday afternoon my mail has not been working on my iPhone 4. It will not load any new messages, just keeps spinning and saying checking for mail. Any suggestions?
     
  2. Krayzie116
    Expand Collapse
    macrumors 6502

    Joined:
    Mar 31, 2010
    #2
    have you tried to delete you mail account and re-adding it?
     
  3. MorganK
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Apr 13, 2010
    Location:
    Mobile, AL
    #3
    I just did and still not working.

    It is my Gmail account that will not load anything new. My Me one is fine (although rarely used so I didn't realize that until a few moments ago).
     
  4. samcraig
    Expand Collapse
    macrumors P6

    Joined:
    Jun 22, 2009
    #4
    Did you try rebooting your phone?

    Did you try resetting network settings?
     
  5. nunes013
    Expand Collapse
    macrumors 65816

    nunes013

    Joined:
    May 24, 2010
    Location:
    Connecticut
    #5
    my school exchange mail stopped working 2 days ago, i can get messages but it wont send, ill let u know if i can fix it
     
  6. MorganK
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Apr 13, 2010
    Location:
    Mobile, AL
    #6
    I tried both yesterday to no avail. Just rebooted again and it's working. Weird! Thanks for the suggestions everyone.
     
  7. ChrisSD
    Expand Collapse
    macrumors member

    Joined:
    Apr 24, 2010
    Location:
    San Diego
    #7
    I have the same issue with my mail. Push notifications don't seem to work as well as 3.x OS. It has to be a bug with 4.0.1. Rebooting does fix it but it gets annoying.
     
  8. timerollson
    Expand Collapse
    macrumors 65816

    Joined:
    Dec 4, 2005
    Location:
    heretothere
  9. Es Paul
    Expand Collapse
    macrumors member

    Joined:
    Jul 9, 2010
    #9
    I'm having the same problem. I deleted the yahoo account then re-installed it. That worked for a day. Now I'm having the same problem again. Push is not working. Whenever I go to my yahoo account, only then does it receive mail. The only problem I have with this phone.
     
  10. Kuroth1
    Expand Collapse
    macrumors newbie

    Joined:
    Aug 9, 2010
    #10
    Same issue here but on my Itouch... Yahoo mail was working until about 3 or 4 days ago.. Now just sits there saying "Checking Mail"

    I noticed Yahoo has an App for the Ipod for Yahoo mail.. Anyone try the App?? What is the difference between using this App and just setting up your default Email to Yahoo???
     
  11. Wilcha
    Expand Collapse
    macrumors newbie

    Joined:
    Jun 29, 2010
    #11
    Mine does this every once in a while or just loads blank messages. To fix it, all I do is go to the app drawer and close mail from multitasking. Usually fixes any problem I have with mail.
     

Share This Page