my japanese keyboard doesn't let me type characters

Discussion in 'Mac Help/Tips' started by noises, Jan 26, 2003.

  1. noises macrumors newbie

    Joined:
    Jan 26, 2003
    Location:
    japan
    #1
    :( please help,

    i just aquired a fantastically cheap used iMac dv from a japanese mac mart with a japanese keyboard & got it running os x in the queens english, but all the characters like: £@$%&^*()*^':';} are in all the wrong places.

    for eg. when i press the button labelled '&' (ie 'shift' plus '6') i get a bloody '^'.

    why why why??

    i've been fiddling around inside the system preferences for days; under 'international' & 'keyboard' but i'm just stumped.

    again, please help, i'm a complete mac newbie, but by jove i love this os x thingie.
     
  2. iAlan macrumors 65816

    iAlan

    Joined:
    Dec 11, 2002
    Location:
    Location: Location:
    #2
    Beleive it or not, but Japanese, US English and British English keyboard layouts are all different.

    I thin a US English OS is closest to a Japanese keyboard layout.

    I have US english set for my Japanese keyboard and here ar teh number key 1-9 !"#$%&'() and the character keys (next to the PLM keys) @[;:],./_ and `{*}<>?_

    So, set your OS to US English.
     
  3. irmongoose macrumors 68030

    irmongoose

    Joined:
    Dec 3, 2001
    Location:
    Sometimes Tokyo, sometimes California
    #3
    This is the reason I wanted Apple Japan to have an English keyboard option when I bought my beige G3 a few years ago... I was too used to the English layout that it got unbearable using the Japanese one... luckily they were selling an old English keyboard for about a buck at my school's white elephant sale.

    But by the time I got my FP iMac they had that option... so I was all happy :D




    irmongoose
     
  4. noises thread starter macrumors newbie

    Joined:
    Jan 26, 2003
    Location:
    japan
    #4
    it worked!

    ;) thank you,

    the characters and have all come back home.

    but can anybody tell me how to get that bloody yank flag off my menu bar??
     
  5. irmongoose macrumors 68030

    irmongoose

    Joined:
    Dec 3, 2001
    Location:
    Sometimes Tokyo, sometimes California
    #5
    Re: it worked!

    disable any keyboard languages you have enabled except the one you want to keep (US English)... that flag is there to change the layouts between the different languages.




    irmongoose
     
  6. noises thread starter macrumors newbie

    Joined:
    Jan 26, 2003
    Location:
    japan
    #6
    thanks

    take a bow, irmongoose.

    also thanks to iAlan & evildead & yamadataro & kansaigaijin.

    somebody over at the ****ed gaijin forums recommended macrumors to me & you`ve made me a :) man.
     

Share This Page