My Mac can't see my iPod- only that it's charging

Discussion in 'iPod' started by mikebatho, Jun 20, 2008.

  1. macrumors 6502a

    Jun 1, 2004
    Greater Manchester UK
    My Mac is no longer seeing my ipod. It's a 2nd gen nano.

    I've had my mac in storage for a week or two, and when I set it up again, I was asked to update various bits of software, one of which was itunes, to the current version. I'm on OSX 10.4.11

    Now, when I plug my ipod in, it reads that it's charging, but I don't get the 'do not disconnect' message, and it doesn't show on my desktop, anywhere else on my mac, or in itunes.

    What's going on...?

    I've tried doing some searches and done the appropriate checklist on the apple site, and the only thing I've left to try is doing a restore, which I'm loathe to do, as I'll have to back all my music up...

    Any ideas?
  2. thread starter macrumors 6502a

    Jun 1, 2004
    Greater Manchester UK
    Can anyone help?

    I've even plugged someone else's iPod into my mac, and iTunes sees it immediately...

    Please tell me I don't have to restore....?????
  3. macrumors 6502a


    Mar 15, 2007
    Did the battery in the iPod drain all the way? I've found that my daughter will run her iPod all the way down and when I plug it in it isn't recognized until after it has charged for a while and I reconnect it.
  4. macrumors Core


    Feb 9, 2008
    San Jose (CA)
    Are you using the Firewire cable? Nano and 5th Gen Classics don't support Firewire.
  5. macrumors regular

    Sep 10, 2005
    Try resetting the iPod (hold menu and select buttons for 5-10 secs). If that doesnt work, try disk mode (reset then immediately hold select and pause/play buttons). See if it loads in disk mode (should do it ok) if it does reset again and see if it is now recognised normally.

Share This Page