1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

My new iPod Nano 8 gig is unresponsive- won't turn on

Discussion in 'iPod' started by leekohler, Jan 24, 2009.

  1. macrumors G5

    leekohler

    #1
    Guys- I turned on my Nano today to check the time and then turned it off. A friend I was with saw it and wanted to check it out. I tried to turn it on and I got nothing! No light, no response whatsoever.

    I just hooked it up to my computer and again- nothing. It's dead. iTunes didn't even start up. Any body know what this is?
     
  2. Demi-God (Moderator emeritus)

    EricNau

    #2
    Have you tried resetting it? ...Press and hold the Menu and Center (Select) buttons simultaneously until the Apple logo appears, about 6 to 8 seconds.
     
  3. macrumors G5

    leekohler

    #3
    That did it. what happened?
     
  4. Demi-God (Moderator emeritus)

    EricNau

    #4
    It's hard to say exactly what happened, but it's not uncommon nor anything to worry about.
     
  5. macrumors G5

    leekohler

    #5
    Oh good. That really freaked me out.
     
  6. macrumors G3

    TuffLuffJimmy

    #6
    Just remember that those buttons are called the home and sleep/wake button. Since neither of them take you to a menu, and neither of them select anything.
     

Share This Page