My Powerbook has slowed down. HELP!

Discussion in 'General Mac Discussion' started by Wano, Aug 10, 2003.

  1. macrumors 6502

    Joined:
    Oct 23, 2002
    #1
    Well in just the last few days while using my 17 in powerbook I have noticed it´s been slower than it used to be. So, I decided to run xbench and my results were about 5 points lower than about 2 weeks ago. Now, it's 87.15 and it used to be 92.7, I repaired disk permisions and erased some stupid stuff I downloaded, but my results were still the same.

    So, my question is...what are some things I can do to speed up my computer, besides buying memory? Does safari and internet explorer save internet files on the computer that slows it down, if so how do I erase these? Also, does the system log every action and save it somewhere which slows it down?

    Any help/advice is greatly appreciated!
     
  2. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #2
    How full is the HD partition that's holding the boot OS?
     
  3. thread starter macrumors 6502

    Joined:
    Oct 23, 2002
    #3
    20gb used and 35gb available...it's the same as it was about 2 weeks ago
     
  4. Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #4
    did you try:

    sudo ssh /etc/daily

    sudo ssh /etc/weekly

    sudo ssh /etc/monthly

    It might work
     
  5. macrumors 603

    shadowfax

    Joined:
    Sep 6, 2002
    Location:
    Houston, TX
    #5
    i thought it was sh, not ssh? what's the difference?

    anyways, another thing worth trying is opening disk utility and repairing permissions. good luck.
     
  6. macrumors 68020

    daveL

    Joined:
    Jun 18, 2003
    Location:
    Montana
    #6
    ssh is the secure shell. It's normally used to access remote systems. Everything over the wire is encrypted and you have to have proper credentials to login.

    You would not use ssh, normally, on your local machine, unless you're really paranoid and think that someone else on the same machine is syping on your terminal session.
     
  7. macrumors 603

    shadowfax

    Joined:
    Sep 6, 2002
    Location:
    Houston, TX
    #7
    ah, good to know. as you can see, i am so lax with my security measures that i didn't even know they existed. thanks for the info.
     
  8. macrumors 68020

    daveL

    Joined:
    Jun 18, 2003
    Location:
    Montana
    #8
    Re: My Powerbook has slowed down. HELP!

    You might try running "sox" (google it). It's a shareware utility that is supposed to speed things up. You can try before you buy, so give it a shot and see if it helps. I've tried it and didn't notice much difference, but then, my system wasn't running slow to begin with.

    HTH
     
  9. macrumors 603

    Joined:
    Mar 2, 2002
    #9
    A more important question to ask is:

    "How can I prevent my system from slowing down?"

    This occurs when more extensions are installer, or when you install alpha/beta software. You know which programs you use that have version numbers starting with 0. ?? Those are alphas/betas.

    The best way to prevent system slowdown is to keep your computer "clean". Don't install software you won't use (or don't see enough need to use). Avoid alpha/beta/development software whenever possible. (i.e. Don't install a beta of Panther an expect to have optimum and stable performance. :rolleyes:) Don't download spam mail or open unidentifiable email attachments unless you are sure that they don't have viruses in them. :eek:

    Avoid running too much P2P software (if you use that). Also, watch out for corrupt files that may leak throughout your system, causing more and more speed reduction per usage of your computer.

    DO NOT use a program to help you optimize the speed of your system, unless it is from a MAJOR software developer (Aladdin, Roxio, Symantec etc.). Even then, I would not recommend using them.

    Keep your system up to date with the latest OS X software, as you would any major software.

    The #1 cause of computer system speed bogs is: The User. The #1 way to prevent them is: The User.
     
  10. macrumors 6502a

    Schiffi

    Joined:
    May 22, 2003
    Location:
    Missouri
    #10
    Viruses? What are those?

    BTW: Macjanitor does those ssh or sh commands (whatever they're called) and it's quite good. freeware.
     
  11. macrumors 603

    Joined:
    Mar 2, 2002
    #11
    A virus is a program.

    But...its intent is to perform one task while replicating itself. Watch out for harmful viruses that are intended to corrput your directory tree or worse.

    Remember Code Red from 2001? Viruses were spread throughout the web attacking networks.
     
  12. macrumors 603

    shadowfax

    Joined:
    Sep 6, 2002
    Location:
    Houston, TX
    #12
    hold everything, i thought they were nonliving parasites that feed on living cells to perpetuate themselves? :confused:
     
  13. macrumors 603

    Joined:
    Mar 2, 2002
    #13
    You mean the computer is alive? :eek: :eek: :p
     
  14. macrumors 68040

    Powerbook G5

    Joined:
    Jun 23, 2003
    Location:
    St Augustine, FL
    #14
    I'd say do the routine maitainence through terminal. The weekly should give your system a good cleaning, I'm not sure how long you've used your system, but perhaps running the monthly will work for you, as well. As far as MacJanitor...why download a program to do something you can easily do through the terminal? But by all means, optimize your system and give it a good cleaning.
     
  15. macrumors regular

    Joined:
    Apr 19, 2003
    Location:
    Philadelphia, Pennsylvania
    #15
    I think he was being sarcastic when he said, "Viruses? What are those?", since (as far as I know) there are no OS X viruses.
     
  16. macrumors 604

    MrMacMan

    Joined:
    Jul 4, 2001
    Location:
    1 Block away from NYC.
    #16
    There are Viruses on Mac Os X, but luckily they have been out for a while and are easy to fix.

    I've used SOX, its decent, but mostly I just do a DiskWarrior or Daily, Weekly and Monthly disks.
     
  17. macrumors 65816

    mgargan1

    Joined:
    Feb 22, 2003
    Location:
    Reston, VA
    #17
    i have the same computer, and i got 88, so i think you should be fine...
     
  18. macrumors member

    Joined:
    Jun 25, 2003
    Location:
    South Beach
    #18
    I also have an Al 17 inch with 1GB RAM.

    Before repairing permissions I got 94.99; after permissions I got 96.88.

    How much RAM do you have Wano?

    Also, to find out where the problem is, you should save the results from Xbench so that you can compare the specific components that are being tested. Maybe it isn't a hard drive issue at all.
     
  19. macrumors member

    Joined:
    Aug 5, 2003
    Location:
    Scheßlitz, Oberfranken, Bavaria, Germany
    #19
    Hi,

    do you have the results of the xbench run?
    If you have same which of the sub-benchmarks gives a lower result?
    Furthermore, what happens if you ran xbench as the first application after you booted the systen? Do you still get the same results?

    Greetings
    Peter
     
  20. thread starter macrumors 6502

    Joined:
    Oct 23, 2002
    #20
    i have 512 mb ram. before i ran it i repaired permissions and rebooted.
     
  21. thread starter macrumors 6502

    Joined:
    Oct 23, 2002
    #21
    wow! I just got 94.07..this is weird but cool...are there any background apps or caches that slows things down?
     
  22. macrumors 68020

    daveL

    Joined:
    Jun 18, 2003
    Location:
    Montana
    #22
    Well, I just ran Xbench twice on a freashly booted Panther beta and get different results each time. Even though the overall score is close, the sub-test varied quite a bit. I just don't think Xbench is a very reliable benchmark. Other people run it and find Panther 20% faster than Jag. I ran it and Jag was a hair faster than Panther, even though subjectively it feels *alot* faster than Jag.

    As I said in a previous post, Xbench went 1.0 last January and hasn't had a single update since. I know for sure that they have not produced a build with gcc 3.3. So what are the results really telling you?
    I think you would have to be able to run it in single user mode to get anything close to consistent results, but then you wouldn't be able to do any of the UI and graphics tests, which are very important.

    Just my take on it.
     

Share This Page