My profile got "reset" somehow??

Discussion in 'macOS' started by Poff, Dec 4, 2005.

  1. Poff macrumors 65816

    Poff

    Joined:
    Sep 16, 2003
    Location:
    Stavanger, Norway
    #1
    Hello,

    I hope some of you people can give me some advice on this one..

    Yesterday I turned off my computer, just the way I always do it. It seems to be quite normal.

    When I turn it on, the first thing that greets me is the "Welcome to iChat AV" box, bragging about the new features and wanting me to set up my iChat.

    The Dock is reset to the standard dock when you first install the OS.

    All my mails are deleted. (Tho I can still see the mailboxes if I navigate to library > mail) I'm on 10.3.9. Anyone heard about this before? I wonder what could have happened. Safari bookmarks are still here, with the addition of the standard "Apple" ".Mac" "Amazon" and so on bookmarks. Safari log is gone. So is the preferences. (Apple+T won't give me a new tab, for example.)

    Anyways, the most important thing is the mailbox, and how I can "retrieve" my mails. I'm afraid to just add the old mailaccounts, in case all of my old mails will be deleted then.. Anyone got ideas?



    ...I guess this is why a backup is a good thing..
     
  2. Poff thread starter macrumors 65816

    Poff

    Joined:
    Sep 16, 2003
    Location:
    Stavanger, Norway
    #2
    Hmm.. I just noticed. Animated gifs will now animate once in Safari, and not continuesly. v.1.3.1 strange..
     
  3. Poff thread starter macrumors 65816

    Poff

    Joined:
    Sep 16, 2003
    Location:
    Stavanger, Norway
    #3
    Hmm.. I logged on again now, and everything was reset again.. Anyone got a take on this? Seems everything gets reset every time I turn off the computer all of a sudden..

    Anyone got a take on this?
     
  4. pknz macrumors 68020

    pknz

    Joined:
    Mar 22, 2005
    Location:
    NZ
    #4
    I have had this happen before. Quite a while ago. All your programs and dock will have been reset so everything is being opened for the 'first' time.
    I do not know what causes it. You shouldn't have lost any of your documents though
     
  5. pknz macrumors 68020

    pknz

    Joined:
    Mar 22, 2005
    Location:
    NZ
    #5
    Are you using a laptop? You might want to get a new battery.
     
  6. Poff thread starter macrumors 65816

    Poff

    Joined:
    Sep 16, 2003
    Location:
    Stavanger, Norway
    #6
    Hmm.. Nopz. iMac G4. Biggest problem is getting the mails back into mail.app tho.. Good to hear someone else has experienced this, as I guess it increases the chances of someone knowing what it is..
     
  7. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #7
    You didn't rename your home folder yesterday...?

    Have you seen of there's an extra one in /Users/?
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    Go into your /Users/ folder (in the root of your main hard drive) and see if your accounts are really still there....

    There have been a number of threads like this in the past, and most often, the culprit is that somehow the user has accidentally been logged into the wrong account or created a new one somehow. But that the files are all still safe and sound in the original account.
     
  9. Poff thread starter macrumors 65816

    Poff

    Joined:
    Sep 16, 2003
    Location:
    Stavanger, Norway
    #9
    Nope. No new account, still the same old. No new files in /Users. All my files are still here, it's just the actual preferences for some programs that have disappeared. Seems to relate to Apple-programs.

    Places I've noticed it:
    Finder prefs
    Safari prefs
    Keychain prefs
    iPhoto prefs (all albums deleted, pics still there)
    iTunes prefs (library gone, songs still on harddrive)
    Mail prefs (and thus the link to all my old mail-accounts and thousands of mails, even though they are still in library>mail.)

    it seems the prefs of all apple-related programs, including Finder, have been deleted. All files are still on my account. Mailboxes still in library. Songs still there. Documents and movies and pictures still there. Just the prefs of all apple-programs. Does apple store its program preferences somewhere special?

    I have filevault activated. Don't know if some error there could cause this. I got a notice from iTunes that the old music library was damaged, and a new one had to be made. hmm...
     
  10. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #10
    Wow...strange...and frustrating! :( The prefs files you're looking for are in ~/library/preferences/
     
  11. Poff thread starter macrumors 65816

    Poff

    Joined:
    Sep 16, 2003
    Location:
    Stavanger, Norway
    #11
    Thanks for the link. Strange thing, a lot of preferences for programs I haven't used for quite some time are still in there, so the prefs cannot have been deleted.

    Another strange thing is that 3d party programs don't seem to have changed, and none of their prefs are different or deleted.

    Reminds me of viruses in the windows world. Ugh.
     

Share This Page