My Router Is Preventing My Access To My Printer

Discussion in 'macOS' started by bobber205, Oct 1, 2006.

  1. bobber205 macrumors 68020

    bobber205

    Joined:
    Nov 15, 2005
    Location:
    Oregon
    #1
    Troubling.... and inconvenient.

    My MacBook is different from the other computers (3) in the house. The other computers have all local ip addresses (192.168.0.xx). My does not. It is an outside IP address that it public on the net. (To use torrents, I had open up ports..)

    All the other computers are connected in a network, along with my macbook, via a wireless router. The printer is hooked up to our G4 that is in the router via ethernet.

    My wireless Mac Mini can access the printer through "shared printers", but my macbook cannot see it.

    I'm pretty sure it's because my ip address is not "local". How do I get around this?
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    When asking for help with a peripheral such as a printer, you should give the model of the peripheral. I am guessing that your printer is connected via USB to one of your other computers and is shared over your network. If this is the case, you have to use the CUPS driver for your printer. This issue has come up on this forum too many times to count. Just search on CUPS and you should find all the information that you need.
     
  3. rhoydotp macrumors 6502

    rhoydotp

    Joined:
    Sep 28, 2006
    #3
    you may have to open the router port 631 from the DMZ and re-direct that port to the IP of the G4. btw, what kind of router do you have?
     
  4. bobber205 thread starter macrumors 68020

    bobber205

    Joined:
    Nov 15, 2005
    Location:
    Oregon
    #4
    It's a Canon PIXMA MP170.
    The router is 2WIRE.
     
  5. bobber205 thread starter macrumors 68020

    bobber205

    Joined:
    Nov 15, 2005
    Location:
    Oregon
    #5
    I tried adding a printer and using this for the address (correct Ip, I checked).

    192.168.0.65:631

    No dice... :(
     
  6. beatsme macrumors 65816

    beatsme

    Joined:
    Oct 6, 2005
    #6
    what you could do is this:
    1) Go to System Preferences
    2) Select Network
    3) in the Network pane, click on the drop-down menu that says "Location"
    4) in the Location menu, you should have an option called "New Location." Go ahead and select that; it'll ask you to give it a name...name it "Print" or something.
    5) Configure this Location to work on your home network, and then click on "Apply Now"

    this should give you a new Network Location that you can use to connect to your home network. When you want to go back to your public IP connection, just go to the Network preference pane, select the "Location" menu, and switch back to the old, public IP network.

    hope this isn't condescending...
    you get the idea, right? You're saving two separate network configurations, and you'll be able to switch between the two.

    Hope this helps :)
     
  7. bobber205 thread starter macrumors 68020

    bobber205

    Joined:
    Nov 15, 2005
    Location:
    Oregon
    #7
    Excellent! Thanks! :D
     

Share This Page