Nana's iMac has wireless issues!

Discussion in 'iMac' started by hippiechickadee, Dec 30, 2012.

  1. macrumors newbie

    hippiechickadee

    Joined:
    Dec 30, 2012
    #1
    My Nana has an iMac. For months now, it wont connect to the internet when it's turned on. The only way it will connect is to unplug the wireless (router) and plug it back in.

    I am ALMOST sure it's not the wireless because her iPad and my iPhone never has a problem connecting to the internet. Just the iMac.

    I believe it's an early 2010 and it's had all it's updates that were available.

    Can anyone help?
     
  2. macrumors regular

    NVRENUF!

    Joined:
    Mar 19, 2012
    Location:
    PERTH, Australia
    #2
    I would default the router and set it up again
    checking the type of network and password type is set,

    Also test another wifi router. Bring yours from home and try that
    need to rule out the router.

    Delete / forget the network from the imac and re connect again and test.
     
  3. macrumors newbie

    Joined:
    Dec 28, 2012
    #3
    Not sure if this will help but, I had the same issue like you recently whereas my iMac, mbp wouldn't be able to connect to my wifi router which was a netgear I assumed it was my computers issue n not my router, but after borrowing my friends MBA I had the same
    Problem so I replaced my router and after that I had no issue.
     
  4. thread starter macrumors newbie

    hippiechickadee

    Joined:
    Dec 30, 2012
    #4
    Thank you both!

    I will bring my router and give it a shot!

    I'll let you know
     

Share This Page