Need help installing Couch Surfer on ATV

Discussion in 'Apple TV and Home Theater' started by dylanbrown, Nov 4, 2008.

  1. macrumors 6502

    Joined:
    Aug 20, 2008
    Location:
    Scotland
    #1
    Hi,

    I have installed Boxee and XBMC with the help of the ATV USB Creator, in the process I also enabled SSH.

    After doing this, I guessed it would be fairly easy to install some plug-ins. (CouchSurfer, ATV Files etc...)

    Anyway, I have the instructions to install CouchSurfer, but don't know what I'm doing wrong.

    Through CyberDuck, I uploaded the whole CouchSurfer folder to the /Users directory.

    I can access ATV via SSH in Terminal, then I write the command /Users/couchsurfer-0.4-2.2-installer, then I do sudo ./install couch surfer, and it says 'Directory not found/does not exist (Or something like that)

    What am I doing wrong?
     
  2. macrumors 6502a

    Joined:
    May 15, 2007
    #2
    Where did you get your original instructions from ?
    Did you unzip the installer package ?
     
  3. thread starter macrumors 6502

    Joined:
    Aug 20, 2008
    Location:
    Scotland
    #3
    Yep - I unzipped the file...
    Here are the instructions provided:

    To install it, you will need to copy this folder to your AppleTV. You can copy it to the home folder of the 'frontrow' user if you wish, although its location doesn't really matter.

    Done that - put it into /Users/frontrow

    Next, you need to open an SSH connection to your AppleTV, like so:

    ssh -1 frontrow@<your_appletv_address>

    When prompted for a password, enter 'frontrow'.

    Done that

    Now go to the directory where you placed this folder on your AppleTV and type the following command:

    At this point I type in the directory, then do the following command

    sudo ./installcouchsurfer

    Done

    When prompted for a password, enter 'frontrow' again.

    Done, then I get this message "command not found"


    [​IMG]
     
  4. macrumors 6502a

    chas0001

    Joined:
    Sep 18, 2006
    Location:
    Alicante, SPAIN
    #4
    so you copied the folder 'couchsurfer-0.4-2.2-installer' to the apple tv into the /users/frontrow/ directory.

    You then need to cd into the couchsurfer-0.4-2.2-installer directory when connected to the appletv e.g

    cd /users/frontrow/couchsurfer-0.4-2.2-installer/

    then make the installer exectuable (just in case)

    chmod +x installcouchsurfer

    then run the installer

    sudo ./installcouchsurfer
     
  5. thread starter macrumors 6502

    Joined:
    Aug 20, 2008
    Location:
    Scotland
    #5
    Cheers chas0001!

    [​IMG]
     
  6. macrumors newbie

    Joined:
    May 20, 2003
    #6
    please help. i'm trying to do the same, but when i go to terminal and type

    Code:
    ssh -1 frontrow@appletv.local
    i get the message

    Code:
    Protocol major versions differ: 1 vs 2
    what do i do? this is the latest version of couchsurfer (0.4(2.2)) and i'm trying to install it on aTV 2.2 (which already has boxee/xbmc on it via the easy patchstick method).
     
  7. thread starter macrumors 6502

    Joined:
    Aug 20, 2008
    Location:
    Scotland
    #7
    To SSH into the Apple TV, if you have enabled SSH via the ATV-USB Creator, is to go into terminal and type:

    ssh frontrow@appletv.local

    You will be asked for a password, type the following:

    frontrow

    When typing in the password, no letters will appear, but press enter afterwards and you should be logged-in.

    Then find where you put the CouchSurfer file. Then...

    (I placed the CouchSurfer file in Users/Frontrow/)

    Hope this helps!
     
  8. macrumors newbie

    Joined:
    May 20, 2003
    #8
    never mind -- i quit, relaunched terminal, and tried it again, and lo and behold, this time it worked! very weird. i now have couchsurfer running happily on atv.
     

Share This Page