Need help please! Messaging with photos on S4

Discussion in 'Alternatives to iOS and iOS Devices' started by Tikatika, May 6, 2013.

  1. macrumors 6502

    Tikatika

    Joined:
    Mar 12, 2012
    Location:
    Northern California
    #1
    Been looking everywhere for answers and hoping all you smart people can help me.

    Am unable to receive any incoming photos. Text comes through, photos can't be downloaded.. I have auto-retrieve enabled. I even got GO SMS Pro and it doesn't work on that either.

    And worse is If I take a pic and try to send it via messaging, I get the following popup:

    "No network connection. Mobile data is disabled. This message will be sent when mobile data is enabled."

    I have to enable 4G in my house that has wifi in order to text a picture???????? I have a limited data plan. That is so not going to happen. (Sorry, upset at the moment).

    i hope I am just missing something and there is a fix for this. Messaging with pictures is a big part of what I do with a smartphone.

    Help please!
     
  2. macrumors 6502a

    Opstech

    Joined:
    Jan 5, 2010
    Location:
    California
    #2
    If its an ATT service you'll need to switch your plan to a smart phone plan. They'll keep your settings. or you can change the APN settings
     
  3. thread starter macrumors 6502

    Tikatika

    Joined:
    Mar 12, 2012
    Location:
    Northern California
    #3
    I have a smart phone plan with AT&T, just have the smallest data plan. How do I change APN settings please?
     
  4. macrumors 6502a

    Joined:
    Jul 12, 2011
    #4
    Have the same problem every now and then with my Nexus 4 on AT&T.

    I have also seen others with Android phones on AT&T encounter this issue. Although I am not sure if it is limited to AT&T, but this is definitely not the first time I have heard someone have an MMS problem with Android.
     
  5. macrumors 6502a

    Opstech

    Joined:
    Jan 5, 2010
    Location:
    California
    #5
    http://www.4gtricks.com/2012/11/att-apn-4g-settings.html?m=1
     
  6. thread starter macrumors 6502

    Tikatika

    Joined:
    Mar 12, 2012
    Location:
    Northern California
    #6
    Thanks so much for trying. Followed all the instructions and whe I clicked on Access point Names, it brought up AT&T Phone only. No 3 dots. Clicking on AT&T Phone took me to the edit screen and it is greyed out. My phone is not unlocked :(

    Going to pay a visit to the AT&T store tomorrow.
     
  7. macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #7
    Go back to that screen and tap the menu soft key to the left of the physical home button. That should bring up a menu where you can add a new APN.

    *edit* One of the things I've figured out in my time using Android phones...if people send multiple pictures in the same message, you're going to get something that looks like a slideshow. They need to send one picture at a time. Sometimes, the pictures won't download properly if they type in text with the picture...they need to send the message and any accompanying text separately.

    It's annoying, but the problem is that carriers like AT&T gave Apple this sweet deal when it came to MMS. This is definitely a network issue, not a phone issue. Until those of us using Android phones make a big enough stink about it to the carriers, it's never going to change.
     

Share This Page