Need help troubleshoot a PowerBook G4

Discussion in 'PowerPC Macs' started by tecka, Sep 25, 2010.

  1. macrumors newbie

    Joined:
    Sep 25, 2010
    #1
    I just acquired a free PowerBook G4. I was told it was having some problems; one being the PRAM battery was bad.

    When I try to boot the PowerBook it does the Question mark folder and wont boot. Things I have tried are:

    I tried booking it while holding the option button and it only have a Arrow shaped in a circle (Think its refresh) and a arrow ->. There is no text or other pictures on the screen and the -> arrow does nothing. So im thinking it cant read the hard drive.

    I put a friends OSX dvd and tried to boot from that but it starts spinning the dvd but never boots to the dvd. I'v tried to to hold C, Option (doesn't show the dvd just the refresh arrow and ->)

    I have taken the laptop apart and everything is plugged in.

    While this is a free laptop I didn't want to put too much money in it so I was trying to see where I should start.

    Would a dead PRAM Cause these issues?

    Should I start with buying a new hard drive? Even with a dead hard drive shouldnt it still boot from the dvd? Does that mean I need a new hard drive and cd/dvd reader?

    I was also thinking about sending it to Powerbook Medic but if its just a hard drive I could change that.

    Thank you for helping me trouble shoot this machine!
     
  2. macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    Which version of OS-X are you trying to boot off of? It needs to be the maximum version that model can use (but later than minimum).

    Using the option during boot should show all bootable volumes - so it could be the version you're using isn't compatible.

    Also, if you can tell us which model PBG4 you have, it'd help figure out what it needs.
     
  3. thread starter macrumors newbie

    Joined:
    Sep 25, 2010
    #3
    Thanks for the quick response.

    It is a Model number: A1046

    and the dvd is Mac OS-X 10.4.10.
     
  4. macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #4
    That should work fine. You can run up to the latest Leopard (10.5.8).

    Some Macs didn't like dead PRAM batteries, but I'm not sure on that one. I believe to replace it, you need to replace it and the board it resides on (comes as an assy).

    Have you tried a PRAM reset? Hold down cmd-opt-P-R on startup and keep them down until you hear a second chime.
     
  5. thread starter macrumors newbie

    Joined:
    Sep 25, 2010
    #5
    Iv tried to reset it a few times I did the second chime and even for a 3rd chime.

    I unplugged it and put it back in too.
     

Share This Page