Need help with G5 / 23" Cinema Display...

Discussion in 'Macintosh Computers' started by anastasis, Jun 18, 2004.

  1. anastasis macrumors member

    Joined:
    Apr 6, 2002
    Location:
    Houston, TX
    #1
    Hey,
    I have a dual g5 2ghz with a 23" HD Cinema Display. Up until two days ago everything was working fine. Now I do not get any video feed on the display at all. The light for power is on and I can turn the computer on and put it to sleep using the button on the screen, however nothing shows up. The computer is running because I can eject the optical drive.

    Does anyone have any suggestions as to how I can start to troubleshoot this?
     
  2. ftaok macrumors 601

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #2
    Do you have access to another monitor? Perhaps an old VGA screen that you could plug into the second port on your video card. I believe that G5s came with a DVI to VGA adaptor.

    It could be that your video card is bad. Or maybe your 23" lcd is busted.
     
  3. jimsowden macrumors 68000

    jimsowden

    Joined:
    Sep 6, 2003
    Location:
    NY
    #3
    Call Apple Support. Why is your first instinct to ask here? We don't have the ability to diagnose stuff, plus its FREE! WHats to loose? 1800APLCARE
     
  4. anastasis thread starter macrumors member

    Joined:
    Apr 6, 2002
    Location:
    Houston, TX
    #4
    I know, but I work within a school district so getting support is not that easy unfortunately. I checked it out with a VGA monitor and it worked fine. BLASTED 23" HD DISPLAY!!!!!
     

Share This Page