Need help with my SB600 Speedlight!

Discussion in 'Digital Photography' started by peapody, Jul 24, 2009.

  1. macrumors 68040

    peapody

    Joined:
    Oct 7, 2007
    Location:
    baltimore, md
    #1
    How hard is this to operate? I just picked one up from ebay and when it arrived, I just can't seem to get it to fire. Doesn't the ready lamp just come on automatically? My ready lamp has never been on and I haven't fired one flash yet. I am trying to find more information - maybe my settings are wrong, but it would seem cumbersome to have to make sure I have the right settings every time.

    Sorry guys this is my first speedlight - I normally don't even use one because I take all my photos outdoors and in bright light.
     
  2. macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #2
    I have the SB600, there is an auto setting on there, I pretty much leave mine on that. Just hit the mode button and it should cycle through the various modes - I believe its TTY/Auto (I don't have it with me right now).

    Did you go into a dark room and test? Try the same camera settings with and without the flash, if the internal flash goes off, then the SB600 should. Another stupid question, but did you try fresh batteries?
     
  3. macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #3
    Bright sunlight is a very good use for an SB600. Outdoors the fill-in flash needs a lot of power. Try it. Normally you might want to turn the flash down a bit less than full power. But to see the effect of fill flash try at full power for a while.

    Have you read the user manual yet? You are going to have to

    Also if this came from eBay, maybe it's broken.
     
  4. thread starter macrumors 68040

    peapody

    Joined:
    Oct 7, 2007
    Location:
    baltimore, md
    #4
    This is what I am trying to figure out.
     
  5. macrumors 65816

    Cliff3

    Joined:
    Nov 2, 2007
    Location:
    SF Bay Area
    #5
    Have you reviewed the troubleshooting section in the manual? If the Ebay seller did not provide a manual, then a PDF version is available from the Nikonusa.com site.
     
  6. thread starter macrumors 68040

    peapody

    Joined:
    Oct 7, 2007
    Location:
    baltimore, md
    #6
    Thanks for the advice!

    I put the flash in TTL and tested the internal flash first and then added on the sb600. The popup flash worked while the sb600 remained the same. I also tried fresh duracells, and that didn't work. I would read the manual but I don't have one - will have to try to search online.

    Yup that is what I get from ebay I guess - but for the most part I have had good luck there. Too bad.
     
  7. macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey

Share This Page