Need help with phone number format

Discussion in 'iPhone' started by Hoya1, Oct 15, 2011.

  1. macrumors newbie

    Joined:
    Mar 27, 2009
    #1
    I just got my first iPhone (4s) w/Verizon, and promptly imported all of my contacts from my iPod Touch. It all imported fine, but the phone numbers of all my contacts are showing up in the wrong format, i.e. 1231231234 instead of (123) 123-1234. So when I hit send to initiate a call, it doesn't add the "1" for long distance calling, and the call doesn't go through. Argh!

    I've checked my iPhone's general settings, and it is set to United States, under the International category. If I try to type in a new phone number / edit a number in an existing contact, it seems to think there should only be 2 numbers in the parentheses, with a setup like this: (12) 312 31 23. And as soon as I add the last digit (the "4" in this example), the formatting disappears completely, reverting to the 1231231234.

    What am I doing wrong? Where else can I change a setting? I've done a Google search on this and come up empty handed, except for the idea of checking the "international" setting in general settings, which I've already confirmed.
     
  2. thread starter macrumors newbie

    Joined:
    Mar 27, 2009
    #2
    Update:

    Turns out this is a Verizon-specific problem. In case anyone else comes across it, the fix is:


    1) Open the Phone and dial *228. This is a Verizon over-the-air programming number.

    2) When the system answer press 1 for "Program or activate your phone"

    3) Wait for the call to disconnect. You should get a prompt stating something like, "Settings updated."

    4) Open the Task Manager and kill the Phone, Message, and Contacts Applications

    5) Wait a few minutes (I waited 3 just to be extra safe)

    6) Open the Message App or Contacts list to verify the fix.

    If you are still broken, kill the Message App again, then reboot your phone.


    It has worked for me - the phone numbers are now properly formatted.
     
  3. macrumors 6502a

    Joined:
    Sep 7, 2007
    #3
    Thank you. I had the same problem and your suggestion fixed it.
     
  4. macrumors newbie

    Joined:
    Oct 18, 2011
    #4
    Thanks!

    I was having the same issue with a new Verizon iPhone 4s, and this solution fixed it. Thank you very much!
     
  5. macrumors member

    Joined:
    Oct 14, 2011
    #5
    Just a quick tip that if you store your contact's numbers as:

    + country code-areacode-phone#
    i.e... +1 (212) 123-4567

    Then it will automatically dial the country code when required. This is very helpful if travelling abroad or outside your local calling area - I started doing it 1 month ago with my contacts and it has made a huge difference. No more "Please dial a 1 before the number..blablabla" when calling long distance

    :)
     
  6. macrumors newbie

    Joined:
    Aug 3, 2007
    #6
    Thank you! You saved my day!!

    Love MacRumors...the fix worked exactly as stated.
    Even when I called a VZN rep, they were not able to suggest it, although they were very polite.
     
  7. macrumors newbie

    Joined:
    Dec 6, 2010
    #7
    Thanks Hoya1, I just ran into this problem and was truly baffled. Your solution fixed everything!
     
  8. macrumors member

    Joined:
    Dec 25, 2010
    #8
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I had this issue too and the solution works.Thanks
     

Share This Page