Need: iTunes 4 or 5 installer

Discussion in 'Mac Apps and Mac App Store' started by 1dterbeest, Apr 10, 2006.

  1. 1dterbeest macrumors regular

    Feb 14, 2006
    Waupun, WI
    I need iTunes 4 or 5 installer, because I just
    restarted my computer into 10.2.8

    I don't like the look of iTunes 6 with Jaguar
    and I don't have an iPod or anything like
    that to deal with. I just need somewhere
    to get the installer either for 4 or 5.

    Anyone want to host it or let me know
    where it is hosted?

    ----EDIT: Thanks, I've got iTunes 4.9 (my favorite one) running!----
  2. Mitthrawnuruodo Moderator emeritus


    Mar 10, 2004
    Bergen, Norway

Share This Page