1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

need some major help with my powermac g4!

Discussion in 'PowerPC Macs' started by imaketouchtheme, Jan 18, 2008.

  1. macrumors 65816

    imaketouchtheme

    #1
    hello,

    I recently purchased 2 sticks of 512 MB if RAM from cdw.com. it is Kingston sdram and i called to make sure it was the right kind, and the guy said exactly right. So I go to put it in and my computer has three slits for memory. I had 1 stick of 256 and 1 stick of 128. So I took out the 128 and put in the 2 512's and my computer wouldn't load. It just stated on the grey apple screen without the grey spinning thing! So I took out the old ram and put the old ones back in, and it did the exact same thing! I called Kingston and they had me reset the pram and that didnt help. I am in big need of help!

    Computer specs are:
    733 MHz powerpc processor
    ~386 MB of originial RAM.
    quicksilver body type.

    If any one has any suggestions please post! This was my only birthday gift and I really want it to work. Btw I could post this because I used my iPod.

    Thanks!

    Paul
     
  2. macrumors 6502a

    JSchwage

    #2
    Did you make sure you pushed the RAM in the slots all the way? Sometimes you have to shove those things in there pretty hard. Make sure the clips on either side go into the grooves on the RAM.
     
  3. macrumors 65816

    imaketouchtheme

    #3
    yes I pushed very hard. It is to my understanding that they close by there selves too?

    Thanks
     
  4. macrumors 6502a

    JSchwage

    #4
  5. macrumors 65816

    imaketouchtheme

    #5
    no luck. Still did the same thing after pressing the button.

    Thanks
     
  6. macrumors 6502a

    JSchwage

    #6
    Try unplugging all your USB devices before you turn it on. See if that works.
     
  7. macrumors 65816

    imaketouchtheme

    #7
    tried that with the new and old ram but it still did the same thing.

    Thanks
     
  8. macrumors 6502a

    JSchwage

    #8
    What monitor are you using? An Apple one? Does it have USB ports on it by any chance?
     
  9. macrumors 65816

    imaketouchtheme

    #9
    I am using a planar monitor and it just has a power supply place and the monitor cord place.

    Thanks
     
  10. macrumors 65816

    teleromeo

    #10
    If you put back the original ram and it starts up correctly you should narrow your issue down to a problem with the new sticks. If it acts the same with the old sticks the problem is elswhere.
     
  11. macrumors newbie

    #11
    You may want to shine a light inside you ram connectors on the motherboard to make sure you did not accidentally grab some debris or damage them when putting the sticks in.
     
  12. macrumors 6502a

    JSchwage

    #12
    Are you trying to boot into Mac OS 9 or Mac OS X? After doing some quick googling, I've found that you're not the only person with this problem.
     
  13. macrumors 65816

    imaketouchtheme

    #13
    it acts the same no matter what ram and what combination I put them in with. I was going to call apple but its 50 bucks for a one time call and I just don't have that money.

    Thanks

    Os x 10.4 tiger. I can't start up without extensions in tiger.

    Thanks
     
  14. macrumors 6502a

    JSchwage

    #14
    Do you have your original Tiger DVD? Try booting off of it by pressing the C key when you turn it on. If you can't open the optical drive tray, try sliding something in between the outer door to open it. From there you should be able to stick a paperclip in a hole on the drive to open it.
     
  15. macrumors 65816

    imaketouchtheme

    #15
    I do have the original install disc but I can't open the tray. There is no button on the drive after I open the panel but there is a tiny button under the power button that I tried hitting several times and it did nothing.
    thanks
     
  16. macrumors 6502a

    JSchwage

    #16
    Isn't there a little hole on the drive somewhere that you can stick a paperclip into? Push it in all the way until the tray pops open. You may have to take the drive out to get at the hole though. I can't remember if the front panel door is large enough to expose the hole.

    Here's an example: http://case-mods.linear1.org/i/pict2435.jpg
     
  17. macrumors 68040

    motulist

    #17
    I hesitate to ask, but... did you have yourself grounded at all times when you were touching the insides of your computer?
     
  18. macrumors 65816

    imaketouchtheme

    #18
    there is no hole there is just a black trey. Also, I tried holding down that little button while I started it up and it started up in open firmware or something but I can't type anything.

    Thanks
     
  19. macrumors 6502a

    JSchwage

    #19
    I was actually thinking about that myself. I didn't want to suggest that he fried the thing just yet though. :p
     
  20. macrumors 65816

    imaketouchtheme

    #20
    I did not but I did touch a grounded metal object before starting.
     
  21. macrumors 6502a

    JSchwage

    #21
    Try taking the drive out of your Mac to open it with the paperclip. Here's a guide: http://eshop.macsales.com/tech_center/manuals/cdinstall/quicksilver300.pdf

    Once you've done that and have the Tiger DVD in it, boot off the DVD by holding down C during boot. Once the CD has fully booted, go into the Utilities menu on the menubar and open Disk Utility. From there you can repair permissions and repair the disk. Hopefully this will fix your problem.
     
  22. macrumors newbie

    #22
    If you immediately press the eject button outside your drive door right after you turn your G4 on it should open for you but may close shortly after.
     
  23. macrumors 6502a

    JSchwage

    #23
    Yeah, but if I remember correctly, the front panel door on the Quicksilver isn't large large enough to expose the button. Plus, there's no eject button on the front panel door on the Quicksilver like there is on the Sawtooths.
     
  24. macrumors 65816

    imaketouchtheme

    #24
    that actually worked!!! I hit the eject button in the keyboard and it opened!! I am now in the disk utilies fixing the permissions. It had taken a while, so is it working right. Also, what exactly does this do?

    Thanks!!
     
  25. macrumors 6502a

    JSchwage

    #25
    Oh, wow. That's weird. I can't eject disks in my MacBook via the keyboard button until I'm in OS X. Or so I thought. I'll have to try it later.

    Anyway, repairing disk permissions is always a good thing to do often when you have problems with your Mac. In most cases you won't need to boot off the DVD though. You can find the Disk Utility in your Utilities folder in your Applications folder.

    Repairing the disk will find and fix any problems on your hard drive.

    Please report back to let me know if it fixed the problem or not! :D
     

Share This Page