Netflix Issues

Discussion in 'Apple TV and Home Theater' started by Cyberius11, Nov 24, 2012.

  1. macrumors regular

    Joined:
    Oct 20, 2011
    #1
    So I have an Apple TV 3. It works great, except for Netflix. It constantly has buffering issues with Netflix, and switches between HD and SD. No other device on my network has problems streaming Netflix HD except for the Apple TV. Hulu and iTunes movies have no problems on the ATV.

    Any ideas? Every service on the ATV works fine but Netflix. I have a static IP set on it.
     
  2. thread starter macrumors regular

    Joined:
    Oct 20, 2011
    #2
    Any ideas?
     
  3. macrumors member

    Joined:
    Jul 27, 2012
    #3
    Have you checked your streaming settings on your Netflix account? There is something like good, better,or best to choose from. You might be set too high for your connection.
     
  4. thread starter macrumors regular

    Joined:
    Oct 20, 2011
    #4
    It's set to max. If it were my connection, other devices would have issues. Nothing else but my Apple TV has problems, as I said before. I can download files at 3+ megabytes (not megabits) per second consistently. My Sony blu-ray player streams Netflix in HD without so much as a hiccup. So do PC's.
     
  5. macrumors newbie

    danbeckemeyer

    Joined:
    Nov 26, 2012
    #5
    I've had a couple issues with my Netflix as well:

    I purchased the ATV3 new just a week ago, so you could say that I'm new to the device, but not other Apple products. Not being at home at the moment, I can't say exactly what update version I have, though I do not recall updating it on install (unless my wife has). I have my ATV running wired to the router. I can say that I do not have buffering issues whatsoever, but occasionally it will appear SD for a moment—seems to be after coming back from a "pause".

    I have an 8mo-old son, so I'm frequently required to "pause" my videos. I'm not sure if replaying from screen-saver state is affecting it or just the short amount of time I have it paused, but trying to replay will render an error (can't remember what exactly it says) and I'm forced to restart the video and find my spot.
     
  6. thread starter macrumors regular

    Joined:
    Oct 20, 2011
    #6
    Gave up on Netflix for ATV. Pretty much only use it for iTunes and AirPlay now. HTPC can do the rest without the frustration...
     
  7. macrumors 68020

    bbeagle

    Joined:
    Oct 19, 2010
    Location:
    Buffalo, NY
    #7
    It's got to be something else. Most likely something to do with your home network. Possibly something to do with the ATV.

    All 3 of my Apple TV 2s have been working fine the past 2 years. We watch Netflix on them everyday, and very few issues. Occasionally, Netflix is down, and once every 6 months or so, Netflix gets stuck, we reboot the ATV, and we're fine.
     
  8. thread starter macrumors regular

    Joined:
    Oct 20, 2011
    #8
    Well, it's not my home network, and its not the port on the router, my connection is fine, and the Apple TV streams iTunes movies in full HD, so yea, it's definitely something wrong with the ATV. My connection is 100% stable and the HTPC is now plugged into the port the ATV was on (it is always hardwired) and I'm sitting here watching Netflix in full HD with no hiccups. Even Hulu works fine on the ATV.
     
  9. macrumors 6502

    Joined:
    Aug 10, 2012
    #9
    i havent had these issues with Netflix on ATV3. Every now and then my connection gets a little muddled but other than that it has run very well.
     

Share This Page