netgear DG834GT WEP Password

Discussion in 'Mac Basics and Help' started by SisterRay, May 25, 2006.

  1. SisterRay macrumors regular

    May 25, 2006
    I have just got a macbook. It is my first Mac.

    First off my Speedtouch ADSL modem would not work.

    No problem, the reason for getting a laptop was to be mobile and connect wirelessly to the internet.

    So I bought a netgear DG834GT, I can connect through the ethernet connection by my wireless connection is giving me lots of problems.

    Originally I tried no security, but everytime I connected from the macbook, it said I needed a WEP password.

    Ok I set up the DG834GT with a WEP password. However this did not work and I get the message "there was an error joining the airport network"

    I have seen this problem all over the internet. Some say a solution is that you cannot type in the pass word which generates the WEP hex 10 digit password, since the aiport card will not translate it.

    They say you have to put in the 10 digit hex number (will any of the four generated work, or is it the one you select). Others say you have to precede the hex with $ or 0x or 0X.

    Can someone give me exact instructions on what the netgear settings should be,and what my setting should be on my macbook. Screenshots would be a great help.Also can you tell me what format to type in the WEP password when connecting.

    Please do not tell me to RTFM. I have been at this for hours. I need help in so may ways.

    Please help
  2. miniConvert macrumors 68040


    Mar 4, 2006
    Kent, UK - the 'Garden of England'.
    This is going to sound crazy... but it asked you that *before* you had set up a WEP password?

    Are you definitely trying to connect to your own router, not a neighbours?

    Also, I assume the router has WPA? Use WPA, not WEP - it's much better and just takes a standard password, no hex.

    If it helps, change the 'SSID' on your router so you easily recognise it. Make sure SSID broadcast is on, so your MacBook can see the router easily.
  3. Queso macrumors G4

    Mar 4, 2006
    I seem to remember having a similar problem with I set up my Netgear.

    The "Passphrase" (to use Netgear terminology) on the router is the WEP Password on the Mac. However, if this doesn't work, the hex key that displays on the router once you've clicked the Generate button can be copied from the Netgear Wireless Settings page and pasted into the WEP 40/128 bit ASCII option on the Mac.

    That worked for me anyway, although it sounds like you've tried that already. Have you thought about using the WPA option instead? Much simpler.
  4. SisterRay thread starter macrumors regular

    May 25, 2006
    I have tried WPA as well, with the same result. I have changed the SSId to show that is definately mine.

    I need step by step instructions for dummies.

    I'm in the UK and my ISP is wanadoo, if that's any help. I must have the correct modem settings otherwise ethernet would not have worked
  5. GilGrissom macrumors 65816


    Mar 13, 2005
    Have you updated to the latest firmware?

    Just to confirm, can your Mac pick up and detect your wireless network by itself ok?...(appears in the drop down list from the wireless icon on the menu bar).

    So it is totally blank in terms of security and the MB still asks for a password?

    Have you got an Access List or Mac Filtering active? Should be under your Wireless Settings, or advanced Wireless settings, not sure how your router interface will look, I only have the DG834G, so a tad older version.
  6. Eniregnat macrumors 68000


    Jan 22, 2003
    In your head.
    I know you have all of this info, but should somebody look up your router info in these forums, it would be nice to have some links for them. I am not trying to talk down to you.

    DG834GT Manual searchable PDF
    includes Mac setup instructions.

    Net Gear DG834gt web pages.

    I like to work from scratch, so if your having problems reset the unit, and the modem.

    Remove any references to the router in your keychain.

    Reset your machine (it can’t hurt).

    Make sure you have set you Mac up for DHCP, or better yet use the network diagnostics. Make sure your Airport card is active.

    Turn off automaticly join Airport networks.
    --->Finder-->Sys Prefs->Network>AirPort Tab, By defauult, join Preferred networks.
    --->Finder-->Sys Prefs->Network>AirPort Tab, Options, If no preferred networks are found, Aske before joining an open network.
    Remove prefered networks that arn't working here:--->Finder-->Sys Prefs->Network>AirPort Tab

    If you want, select Automatically add new new networks to the preferred networks list in the AirPort Tab options.

    Now try to connect. The manual states that the default security setting is for an open network. After you get connected, save the configuration. After that change to personal WPA if you need to. For at least a short time, cut and paste the key into text document or into a password manager like Password Plus[/UR] which can manage passwords across multiple platforms. There is a free light version that can hold 10 passwords securely.
    Life Hacker has a list of other password managers.

    Add this network connection to your keychain once you get it working. I wouldn't stealth the network until you have your connection issues figured out.

    RPG is a good random password generator. You can set it to generate hex or non hex passwords. OSX provides a password generator, but I like this program. You can turn any ASCII password generator into a Hexadecimal generator by limiting the available characters to 0-9,A-F.

    Back your problem.

    After resetting the router and using the network diagnostic, what happens?
  7. Eniregnat macrumors 68000


    Jan 22, 2003
    In your head.
    This is weird. Are people giving terminal commands or writing scripts to connect to their routers. You should not need a preceding $ or 0x.

    When you do set up WPA personal, it (your Mac) will offer you the option of an ASCII or HEX password. I keep it simple and generate a HEX of the proper length. The ASCII is converted to HEX, so the router never knows the difference.

    In all reality, WEEP can be broken, but it is not likely to be. I am not super paranoid, even though I know what tools can trap packets, break weak packets, and do spoofing. I am not preaching against using encryption, just remember that the stronger the encryption, the more computing power is used and non-essential data is sent. This can mean an apparent slowdown in network speed.
  8. SisterRay thread starter macrumors regular

    May 25, 2006
    The wireless access pixies have been in

    It all seems to work now. Since my last post I unplugged the router and shutdown my mac.

    When I returned from work today I set up the router to no security again, this time it recognised I did not need a password and it connected. A good start !!!

    Then I set up a WPA personal password, and again I got connected. So it is all working.

    I don't know what happened!!!

    I hope it is permanently fixed, but I shall have to wait and see.

    Anyway thatnks to all the people who helped. It never fails to amaze me how people on this forum are.

    Now I only have to wirelessly connect my old desktop pc, and learn how to cut and paste using my mac.

    Also anybody know how to resize a windo to full screen ???

    This is how much of a mac novice I am
  9. Queso macrumors G4

    Mar 4, 2006
    Good stuff. Great to hear it's working.

    Cut and paste - easy.

    Apple + x = cut
    Apple + c = copy
    Apple + v = paste

    And don't worry about the max screen window thing. You're a Mac user now. We don't do that :cool:
  10. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    Before version 2.1, Airport required it if your router used hex keys.


Share This Page