Network connection, MAS & iTunes Store

Discussion in 'Mac OS X 10.7 Lion' started by RoelJuun, May 18, 2012.

  1. macrumors 6502


    For a while everything worked okay with Lion, sure there are bugs everywhere and Apple needs to fix these. But suddenly the network connection dropped the whole time with the MAS, iTunes store and Software Update.

    iMac 2009, 2,8 quad, 8 gig ram, 10.7.4. Connected via ethernet.

    A while ago I was experiencing network issues all the time on both my iMac and my Macbook. The iPhone was fine. I have been re-installing Lion and changed every setting on my router but it kept annoying. So I bought an Airport Extreme Base station from Apple. Great router, everything worked again. Until now.

    Suddenly Safari doesn't load pages. So I pull out the ethernet cable, plug it back in and Safari is fine. Adium is fine too. But the MAS and iTunes store just don't work, they will NOT work. So I've restarted the router and the MAS loaded nicely for about 1 minute and it stopped working again. Now I've found out that Software Update doesn't work either. Have done the PRAM resets, rebooted the computer multiple times, restarted the router, pulled out the ethernet. I read suggestions about logging in/out in MAS, but logout 'works' but login just doesn't react. Nothing shows up. The MAS keeps loading for minutes until it says 'Cannot Connect to the App Store'.

    Does anyone have any idea what to do? It is seriously starting to piss me of.
  2. macrumors 68020


    Could it be your ISP? I haven't got network problem this bad from Lion. Did you test download file over internet? Is the speed fine?
  3. macrumors 6502


    The internet speed is not the issue, I just downloaded a file at 4.9 MB/s.
  4. macrumors 6502


    And just when I wanted to check if someone posted something in this thread Safari just stopped working. Ethernet out, ethernet in and it works again…

    Screen Shot 2012-05-18 at 14.22.54.png
    Screen Shot 2012-05-18 at 14.17.27.png
    Screen Shot 2012-05-18 at 14.21.21.png
  5. macrumors 68020

    I am guessing a bit here, but in the absence of info about your settings I'd say check the DNS numbers in Network. And try Google's or maybe OpenDNS. Having DNS problems might produce the symptoms you describe.
  6. macrumors 6502


    It is suddenly gone by 'removing ethernet' from system preferences and add ethernet again. The first 2 times it didn't work but now suddenly it does. Weird because the problems were there when using WiFi.

Share This Page